aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/rdc/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/rdc/profiles')
-rw-r--r--target/linux/x86/rdc/profiles/.svn/entries164
-rw-r--r--target/linux/x86/rdc/profiles/.svn/text-base/ar525w.mk.svn-base12
-rw-r--r--target/linux/x86/rdc/profiles/.svn/text-base/bifferboard.mk.svn-base13
-rw-r--r--target/linux/x86/rdc/profiles/.svn/text-base/r8610.mk.svn-base15
-rw-r--r--target/linux/x86/rdc/profiles/.svn/text-base/sitecom.mk.svn-base12
-rw-r--r--target/linux/x86/rdc/profiles/ar525w.mk12
-rw-r--r--target/linux/x86/rdc/profiles/bifferboard.mk13
-rw-r--r--target/linux/x86/rdc/profiles/r8610.mk15
-rw-r--r--target/linux/x86/rdc/profiles/sitecom.mk12
9 files changed, 268 insertions, 0 deletions
diff --git a/target/linux/x86/rdc/profiles/.svn/entries b/target/linux/x86/rdc/profiles/.svn/entries
new file mode 100644
index 0000000..3b04816
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/.svn/entries
@@ -0,0 +1,164 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/x86/rdc/profiles
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-10-15T18:54:34.437751Z
+33779
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+r8610.mk
+file
+
+
+
+
+2013-03-17T12:12:36.000000Z
+5a8378e7e97b1fbc0ee8eb02fd8ecdad
+2012-10-15T18:54:34.437751Z
+33779
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+429
+
+sitecom.mk
+file
+
+
+
+
+2013-03-17T12:12:36.000000Z
+faeefc186ca72d9d860411eefb6f5fba
+2012-10-15T18:54:34.437751Z
+33779
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+321
+
+ar525w.mk
+file
+
+
+
+
+2013-03-17T12:12:36.000000Z
+eedfb2e268ca3bc9da577e629df6d92b
+2012-10-15T18:54:34.437751Z
+33779
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+288
+
+bifferboard.mk
+file
+
+
+
+
+2013-03-17T12:12:36.000000Z
+753cf1657253b69eda2a9cb812cdb9fe
+2012-10-15T18:54:34.437751Z
+33779
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+338
+
diff --git a/target/linux/x86/rdc/profiles/.svn/text-base/ar525w.mk.svn-base b/target/linux/x86/rdc/profiles/.svn/text-base/ar525w.mk.svn-base
new file mode 100644
index 0000000..d38cb1f
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/.svn/text-base/ar525w.mk.svn-base
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ar525w
+ NAME:=Airlink AR525W
+ PACKAGES:=kmod-rt61-pci kmod-switch-ip17xx swconfig
+endef
+$(eval $(call Profile,ar525w))
diff --git a/target/linux/x86/rdc/profiles/.svn/text-base/bifferboard.mk.svn-base b/target/linux/x86/rdc/profiles/.svn/text-base/bifferboard.mk.svn-base
new file mode 100644
index 0000000..28e1d0e
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/.svn/text-base/bifferboard.mk.svn-base
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/bifferboard
+ NAME:=Bifferboard
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-usb-storage kmod-scsi-core kmod-fs-ext3
+endef
+$(eval $(call Profile,bifferboard))
diff --git a/target/linux/x86/rdc/profiles/.svn/text-base/r8610.mk.svn-base b/target/linux/x86/rdc/profiles/.svn/text-base/r8610.mk.svn-base
new file mode 100644
index 0000000..67fef8a
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/.svn/text-base/r8610.mk.svn-base
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/r8610
+ NAME:=RDC R8610 Evaluation Board
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-hwmon-core kmod-hwmon-w83627hf kmod-ide-core kmod-ide-it821x \
+ kmod-rtc-core kmod-rtc-m48t86 \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+$(eval $(call Profile,r8610))
diff --git a/target/linux/x86/rdc/profiles/.svn/text-base/sitecom.mk.svn-base b/target/linux/x86/rdc/profiles/.svn/text-base/sitecom.mk.svn-base
new file mode 100644
index 0000000..e3b2981
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/.svn/text-base/sitecom.mk.svn-base
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/sitecom
+ NAME:=Devices from Sitecom (WL-153, DC-230)
+ PACKAGES:=kmod-rt61-pci kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,sitecom))
diff --git a/target/linux/x86/rdc/profiles/ar525w.mk b/target/linux/x86/rdc/profiles/ar525w.mk
new file mode 100644
index 0000000..d38cb1f
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/ar525w.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ar525w
+ NAME:=Airlink AR525W
+ PACKAGES:=kmod-rt61-pci kmod-switch-ip17xx swconfig
+endef
+$(eval $(call Profile,ar525w))
diff --git a/target/linux/x86/rdc/profiles/bifferboard.mk b/target/linux/x86/rdc/profiles/bifferboard.mk
new file mode 100644
index 0000000..28e1d0e
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/bifferboard.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/bifferboard
+ NAME:=Bifferboard
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-usb-storage kmod-scsi-core kmod-fs-ext3
+endef
+$(eval $(call Profile,bifferboard))
diff --git a/target/linux/x86/rdc/profiles/r8610.mk b/target/linux/x86/rdc/profiles/r8610.mk
new file mode 100644
index 0000000..67fef8a
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/r8610.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/r8610
+ NAME:=RDC R8610 Evaluation Board
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-hwmon-core kmod-hwmon-w83627hf kmod-ide-core kmod-ide-it821x \
+ kmod-rtc-core kmod-rtc-m48t86 \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+$(eval $(call Profile,r8610))
diff --git a/target/linux/x86/rdc/profiles/sitecom.mk b/target/linux/x86/rdc/profiles/sitecom.mk
new file mode 100644
index 0000000..e3b2981
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/sitecom.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/sitecom
+ NAME:=Devices from Sitecom (WL-153, DC-230)
+ PACKAGES:=kmod-rt61-pci kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,sitecom))