aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sibyte/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sibyte/image')
-rw-r--r--target/linux/sibyte/image/.svn/entries62
-rw-r--r--target/linux/sibyte/image/.svn/text-base/Makefile.svn-base38
-rw-r--r--target/linux/sibyte/image/Makefile38
3 files changed, 138 insertions, 0 deletions
diff --git a/target/linux/sibyte/image/.svn/entries b/target/linux/sibyte/image/.svn/entries
new file mode 100644
index 0000000..fb08a53
--- /dev/null
+++ b/target/linux/sibyte/image/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/sibyte/image
+svn://svn.openwrt.org/openwrt
+
+
+
+2010-04-12T23:15:56.864589Z
+20834
+nico
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:12:48.000000Z
+9f09ad0583c592084c8dc783d4c8f52f
+2010-04-12T23:15:56.864589Z
+20834
+nico
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1102
+
diff --git a/target/linux/sibyte/image/.svn/text-base/Makefile.svn-base b/target/linux/sibyte/image/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..9a25ace
--- /dev/null
+++ b/target/linux/sibyte/image/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(LINUX_DIR)/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
+# uImage
+ dd if=$(KDIR)/vmlinux of=$(KDIR)/$(IMG_PREFIX)-vmlinux bs=64k conv=sync
+ mkimage -A mips -O linux -T kernel -a 0x80100000 -C none -e \
+ 0x80100000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/$(IMG_PREFIX)-vmlinux $(BIN_DIR)/$(IMG_PREFIX)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
+ $(call Image/Build/slug,$(1))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/sibyte/image/Makefile b/target/linux/sibyte/image/Makefile
new file mode 100644
index 0000000..9a25ace
--- /dev/null
+++ b/target/linux/sibyte/image/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(LINUX_DIR)/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
+# uImage
+ dd if=$(KDIR)/vmlinux of=$(KDIR)/$(IMG_PREFIX)-vmlinux bs=64k conv=sync
+ mkimage -A mips -O linux -T kernel -a 0x80100000 -C none -e \
+ 0x80100000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/$(IMG_PREFIX)-vmlinux $(BIN_DIR)/$(IMG_PREFIX)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
+ $(call Image/Build/slug,$(1))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))