aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/harddisk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/orion/harddisk')
-rw-r--r--target/linux/orion/harddisk/.svn/entries96
-rw-r--r--target/linux/orion/harddisk/.svn/text-base/config-3.3.svn-base28
-rw-r--r--target/linux/orion/harddisk/.svn/text-base/target.mk.svn-base14
-rw-r--r--target/linux/orion/harddisk/config-3.328
-rw-r--r--target/linux/orion/harddisk/target.mk14
5 files changed, 180 insertions, 0 deletions
diff --git a/target/linux/orion/harddisk/.svn/entries b/target/linux/orion/harddisk/.svn/entries
new file mode 100644
index 0000000..2aacae5
--- /dev/null
+++ b/target/linux/orion/harddisk/.svn/entries
@@ -0,0 +1,96 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/orion/harddisk
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-05-09T10:48:38.755946Z
+31659
+juhosg
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+config-3.3
+file
+
+
+
+
+2013-03-17T12:12:16.000000Z
+1d8bc3cecb560d0ed6e65504f163e893
+2012-04-29T15:20:40.259027Z
+31528
+juhosg
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+582
+
+target.mk
+file
+
+
+
+
+2013-03-17T12:12:16.000000Z
+27ddf66b0c73caf3e43cbae2824610fd
+2010-11-05T07:33:43.721976Z
+23885
+kaloz
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+370
+
diff --git a/target/linux/orion/harddisk/.svn/text-base/config-3.3.svn-base b/target/linux/orion/harddisk/.svn/text-base/config-3.3.svn-base
new file mode 100644
index 0000000..a566aa5
--- /dev/null
+++ b/target/linux/orion/harddisk/.svn/text-base/config-3.3.svn-base
@@ -0,0 +1,28 @@
+CONFIG_ATA=y
+CONFIG_BLK_DEV_DM=y
+CONFIG_BLK_DEV_MD=y
+CONFIG_BLK_DEV_SD=y
+CONFIG_CRC16=y
+# CONFIG_DM_CRYPT is not set
+# CONFIG_DM_MIRROR is not set
+# CONFIG_DM_SNAPSHOT is not set
+CONFIG_EXT4_FS=y
+CONFIG_FS_MBCACHE=y
+CONFIG_JBD2=y
+CONFIG_MD=y
+CONFIG_MD_AUTODETECT=y
+CONFIG_MD_LINEAR=y
+# CONFIG_MD_MULTIPATH is not set
+CONFIG_MD_RAID0=y
+CONFIG_MD_RAID1=y
+# CONFIG_MD_RAID10 is not set
+# CONFIG_MD_RAID456 is not set
+CONFIG_NLS=y
+CONFIG_SATA_MV=y
+CONFIG_SCSI=y
+CONFIG_SCSI_MOD=y
+CONFIG_USB=y
+CONFIG_USB_COMMON=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_TT_NEWSCHED=y
+CONFIG_USB_STORAGE=y
diff --git a/target/linux/orion/harddisk/.svn/text-base/target.mk.svn-base b/target/linux/orion/harddisk/.svn/text-base/target.mk.svn-base
new file mode 100644
index 0000000..a3a0e41
--- /dev/null
+++ b/target/linux/orion/harddisk/.svn/text-base/target.mk.svn-base
@@ -0,0 +1,14 @@
+#
+# Copyright (C) 2008-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+BOARDNAME:=Internal Hard-Disk
+FEATURES:=targz
+
+define Target/Description
+ Build firmware images for Marvell Orion based boards that boot directly from internal disk storage.
+ (e.g.: Freecom DataTank 2, ...)
+endef
diff --git a/target/linux/orion/harddisk/config-3.3 b/target/linux/orion/harddisk/config-3.3
new file mode 100644
index 0000000..a566aa5
--- /dev/null
+++ b/target/linux/orion/harddisk/config-3.3
@@ -0,0 +1,28 @@
+CONFIG_ATA=y
+CONFIG_BLK_DEV_DM=y
+CONFIG_BLK_DEV_MD=y
+CONFIG_BLK_DEV_SD=y
+CONFIG_CRC16=y
+# CONFIG_DM_CRYPT is not set
+# CONFIG_DM_MIRROR is not set
+# CONFIG_DM_SNAPSHOT is not set
+CONFIG_EXT4_FS=y
+CONFIG_FS_MBCACHE=y
+CONFIG_JBD2=y
+CONFIG_MD=y
+CONFIG_MD_AUTODETECT=y
+CONFIG_MD_LINEAR=y
+# CONFIG_MD_MULTIPATH is not set
+CONFIG_MD_RAID0=y
+CONFIG_MD_RAID1=y
+# CONFIG_MD_RAID10 is not set
+# CONFIG_MD_RAID456 is not set
+CONFIG_NLS=y
+CONFIG_SATA_MV=y
+CONFIG_SCSI=y
+CONFIG_SCSI_MOD=y
+CONFIG_USB=y
+CONFIG_USB_COMMON=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_TT_NEWSCHED=y
+CONFIG_USB_STORAGE=y
diff --git a/target/linux/orion/harddisk/target.mk b/target/linux/orion/harddisk/target.mk
new file mode 100644
index 0000000..a3a0e41
--- /dev/null
+++ b/target/linux/orion/harddisk/target.mk
@@ -0,0 +1,14 @@
+#
+# Copyright (C) 2008-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+BOARDNAME:=Internal Hard-Disk
+FEATURES:=targz
+
+define Target/Description
+ Build firmware images for Marvell Orion based boards that boot directly from internal disk storage.
+ (e.g.: Freecom DataTank 2, ...)
+endef