aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc52xx/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc52xx/image')
-rw-r--r--target/linux/mpc52xx/image/.svn/entries62
-rw-r--r--target/linux/mpc52xx/image/.svn/prop-base/Makefile.svn-base5
-rw-r--r--target/linux/mpc52xx/image/.svn/text-base/Makefile.svn-base26
-rw-r--r--target/linux/mpc52xx/image/Makefile26
4 files changed, 119 insertions, 0 deletions
diff --git a/target/linux/mpc52xx/image/.svn/entries b/target/linux/mpc52xx/image/.svn/entries
new file mode 100644
index 0000000..700c860
--- /dev/null
+++ b/target/linux/mpc52xx/image/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/mpc52xx/image
+svn://svn.openwrt.org/openwrt
+
+
+
+2010-04-12T23:15:56.864589Z
+20834
+nico
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:12:49.000000Z
+0d744b4243db8d9cbd49550b9feb7504
+2010-04-12T23:15:56.864589Z
+20834
+nico
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+555
+
diff --git a/target/linux/mpc52xx/image/.svn/prop-base/Makefile.svn-base b/target/linux/mpc52xx/image/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/target/linux/mpc52xx/image/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/target/linux/mpc52xx/image/.svn/text-base/Makefile.svn-base b/target/linux/mpc52xx/image/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..b63a78d
--- /dev/null
+++ b/target/linux/mpc52xx/image/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+endef
+
+define Image/Build/ext2
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/mpc52xx/image/Makefile b/target/linux/mpc52xx/image/Makefile
new file mode 100644
index 0000000..b63a78d
--- /dev/null
+++ b/target/linux/mpc52xx/image/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+endef
+
+define Image/Build/ext2
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+$(eval $(call BuildImage))