aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cobalt/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/cobalt/image')
-rw-r--r--target/linux/cobalt/image/.svn/entries62
-rw-r--r--target/linux/cobalt/image/.svn/text-base/Makefile.svn-base23
-rw-r--r--target/linux/cobalt/image/Makefile23
3 files changed, 108 insertions, 0 deletions
diff --git a/target/linux/cobalt/image/.svn/entries b/target/linux/cobalt/image/.svn/entries
new file mode 100644
index 0000000..6a00663
--- /dev/null
+++ b/target/linux/cobalt/image/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/cobalt/image
+svn://svn.openwrt.org/openwrt
+
+
+
+2010-04-12T23:15:56.864589Z
+20834
+nico
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:12:27.000000Z
+c8c8bb0b0208fe486a45e183de3e8d84
+2010-04-12T23:15:56.864589Z
+20834
+nico
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+563
+
diff --git a/target/linux/cobalt/image/.svn/text-base/Makefile.svn-base b/target/linux/cobalt/image/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..a690366
--- /dev/null
+++ b/target/linux/cobalt/image/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/cobalt/image/Makefile b/target/linux/cobalt/image/Makefile
new file mode 100644
index 0000000..a690366
--- /dev/null
+++ b/target/linux/cobalt/image/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))