aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/atheros/image')
-rw-r--r--target/linux/atheros/image/.svn/entries62
-rw-r--r--target/linux/atheros/image/.svn/prop-base/Makefile.svn-base5
-rw-r--r--target/linux/atheros/image/.svn/text-base/Makefile.svn-base62
-rw-r--r--target/linux/atheros/image/Makefile62
4 files changed, 191 insertions, 0 deletions
diff --git a/target/linux/atheros/image/.svn/entries b/target/linux/atheros/image/.svn/entries
new file mode 100644
index 0000000..2b79958
--- /dev/null
+++ b/target/linux/atheros/image/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/atheros/image
+svn://svn.openwrt.org/openwrt
+
+
+
+2010-04-12T23:15:56.864589Z
+20834
+nico
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:12:48.000000Z
+72833ce32df15aa82d277367d32abf9a
+2010-04-12T23:15:56.864589Z
+20834
+nico
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2183
+
diff --git a/target/linux/atheros/image/.svn/prop-base/Makefile.svn-base b/target/linux/atheros/image/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/target/linux/atheros/image/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/target/linux/atheros/image/.svn/text-base/Makefile.svn-base b/target/linux/atheros/image/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..a31bf6a
--- /dev/null
+++ b/target/linux/atheros/image/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+ gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
+ dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
+ dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.gz bs=65536 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS2 -v XS2.ar2316.OpenWrt.$(REVISION) \
+ -k $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma \
+ -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ -o $(BIN_DIR)/$(IMG_PREFIX)-ubnt2-$(1).bin
+
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS5 -v XS5.ar2313.OpenWrt.$(REVISION) \
+ -k $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma \
+ -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ -o $(BIN_DIR)/$(IMG_PREFIX)-ubnt5-$(1).bin
+
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS2-8 -v XS2.ar2316.OpenWrt.$(REVISION) \
+ -k $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma \
+ -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ -o $(BIN_DIR)/$(IMG_PREFIX)-ubnt2-pico2-$(1).bin
+
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B np25g \
+ -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
+ -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ $(BIN_DIR)/$(IMG_PREFIX)-np25g-$(1).bin
+
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B wpe53g \
+ -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
+ -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ $(BIN_DIR)/$(IMG_PREFIX)-wpe53g-$(1).bin
+
+ ifeq ($(BOARD),atheros)
+ -sh $(TOPDIR)/scripts/combined-image.sh \
+ "$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma" \
+ "$(BIN_DIR)/$(IMG_PREFIX)-root.$(1)" \
+ "$(BIN_DIR)/$(IMG_PREFIX)-combined.$(1).img"
+ endif
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
new file mode 100644
index 0000000..a31bf6a
--- /dev/null
+++ b/target/linux/atheros/image/Makefile
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+ gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
+ dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
+ dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.gz bs=65536 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS2 -v XS2.ar2316.OpenWrt.$(REVISION) \
+ -k $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma \
+ -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ -o $(BIN_DIR)/$(IMG_PREFIX)-ubnt2-$(1).bin
+
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS5 -v XS5.ar2313.OpenWrt.$(REVISION) \
+ -k $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma \
+ -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ -o $(BIN_DIR)/$(IMG_PREFIX)-ubnt5-$(1).bin
+
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS2-8 -v XS2.ar2316.OpenWrt.$(REVISION) \
+ -k $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma \
+ -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ -o $(BIN_DIR)/$(IMG_PREFIX)-ubnt2-pico2-$(1).bin
+
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B np25g \
+ -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
+ -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ $(BIN_DIR)/$(IMG_PREFIX)-np25g-$(1).bin
+
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B wpe53g \
+ -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
+ -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+ $(BIN_DIR)/$(IMG_PREFIX)-wpe53g-$(1).bin
+
+ ifeq ($(BOARD),atheros)
+ -sh $(TOPDIR)/scripts/combined-image.sh \
+ "$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma" \
+ "$(BIN_DIR)/$(IMG_PREFIX)-root.$(1)" \
+ "$(BIN_DIR)/$(IMG_PREFIX)-combined.$(1).img"
+ endif
+endef
+
+$(eval $(call BuildImage))