aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amazon/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/amazon/image')
-rw-r--r--target/linux/amazon/image/.svn/entries62
-rw-r--r--target/linux/amazon/image/.svn/text-base/Makefile.svn-base30
-rw-r--r--target/linux/amazon/image/Makefile30
3 files changed, 122 insertions, 0 deletions
diff --git a/target/linux/amazon/image/.svn/entries b/target/linux/amazon/image/.svn/entries
new file mode 100644
index 0000000..bb90866
--- /dev/null
+++ b/target/linux/amazon/image/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/amazon/image
+svn://svn.openwrt.org/openwrt
+
+
+
+2010-04-12T23:15:56.864589Z
+20834
+nico
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:12:36.000000Z
+cf795da9e89c7c0f82676b976dc4a7cd
+2010-04-12T23:15:56.864589Z
+20834
+nico
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+803
+
diff --git a/target/linux/amazon/image/.svn/text-base/Makefile.svn-base b/target/linux/amazon/image/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..08f3ba5
--- /dev/null
+++ b/target/linux/amazon/image/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ mkimage -A mips -O linux -T kernel -C lzma -a 0x80002000 -e \
+ 0x80002000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage
+
+ cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(1).image)
+endef
+
+define Image/Build
+ cat $(KDIR)/uImage $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).image
+ $(call Image/Build/$(1),$(1))
+endef
+
+
+$(eval $(call BuildImage))
diff --git a/target/linux/amazon/image/Makefile b/target/linux/amazon/image/Makefile
new file mode 100644
index 0000000..08f3ba5
--- /dev/null
+++ b/target/linux/amazon/image/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ mkimage -A mips -O linux -T kernel -C lzma -a 0x80002000 -e \
+ 0x80002000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage
+
+ cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(1).image)
+endef
+
+define Image/Build
+ cat $(KDIR)/uImage $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).image
+ $(call Image/Build/$(1),$(1))
+endef
+
+
+$(eval $(call BuildImage))