aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'target/imagebuilder/.svn')
-rw-r--r--target/imagebuilder/.svn/entries99
-rw-r--r--target/imagebuilder/.svn/prop-base/Config.in.svn-base5
-rw-r--r--target/imagebuilder/.svn/prop-base/Makefile.svn-base5
-rw-r--r--target/imagebuilder/.svn/text-base/Config.in.svn-base11
-rw-r--r--target/imagebuilder/.svn/text-base/Makefile.svn-base59
5 files changed, 179 insertions, 0 deletions
diff --git a/target/imagebuilder/.svn/entries b/target/imagebuilder/.svn/entries
new file mode 100644
index 0000000..1b2b12a
--- /dev/null
+++ b/target/imagebuilder/.svn/entries
@@ -0,0 +1,99 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/imagebuilder
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-12-02T12:20:43.343746Z
+34439
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+files
+dir
+
+Config.in
+file
+
+
+
+
+2013-03-17T12:12:16.000000Z
+584679cd9a33a596b9850f589fd92b13
+2010-03-30T11:42:41.554160Z
+20598
+nico
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+351
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:12:16.000000Z
+f23b05ecc0a6856514addbc4110b129b
+2012-08-22T15:07:32.119544Z
+33228
+blogic
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2027
+
diff --git a/target/imagebuilder/.svn/prop-base/Config.in.svn-base b/target/imagebuilder/.svn/prop-base/Config.in.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/target/imagebuilder/.svn/prop-base/Config.in.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/target/imagebuilder/.svn/prop-base/Makefile.svn-base b/target/imagebuilder/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/target/imagebuilder/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/target/imagebuilder/.svn/text-base/Config.in.svn-base b/target/imagebuilder/.svn/text-base/Config.in.svn-base
new file mode 100644
index 0000000..23a418b
--- /dev/null
+++ b/target/imagebuilder/.svn/text-base/Config.in.svn-base
@@ -0,0 +1,11 @@
+config IB
+ bool "Build the OpenWrt Image Builder"
+ depends !TARGET_ROOTFS_INITRAMFS
+ depends !PROFILE_KCONFIG
+ depends !EXTERNAL_TOOLCHAIN
+ help
+ This is essentially a stripped-down version of the buildroot
+ with precompiled packages, kernel image and image building tools.
+ You can use it to generate custom images without compiling anything
+
+
diff --git a/target/imagebuilder/.svn/text-base/Makefile.svn-base b/target/imagebuilder/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..a9480ef
--- /dev/null
+++ b/target/imagebuilder/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/version.mk
+
+override MAKEFLAGS=
+
+PKG_OS:=$(word 2,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
+PKG_CPU:=$(word 1,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
+
+IB_NAME:=OpenWrt-ImageBuilder-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))-for-$(PKG_OS)-$(PKG_CPU)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(IB_NAME)
+IB_KDIR:=$(patsubst $(TOPDIR)/%,$(PKG_BUILD_DIR)/%,$(KERNEL_BUILD_DIR))
+IB_LDIR:=$(patsubst $(TOPDIR)/%,$(PKG_BUILD_DIR)/%,$(LINUX_DIR))
+
+all: compile
+
+$(BIN_DIR)/$(IB_NAME).tar.bz2: clean
+ rm -rf $(PKG_BUILD_DIR)
+ mkdir -p $(IB_KDIR) $(IB_LDIR) $(PKG_BUILD_DIR)/staging_dir/host \
+ $(PKG_BUILD_DIR)/target $(PKG_BUILD_DIR)/scripts
+ -cp $(TOPDIR)/.config $(PKG_BUILD_DIR)/.config
+ $(CP) \
+ $(INCLUDE_DIR) $(SCRIPT_DIR) \
+ $(TOPDIR)/rules.mk \
+ ./files/Makefile \
+ ./files/repositories.conf \
+ $(TMP_DIR)/.targetinfo \
+ $(TMP_DIR)/.packageinfo \
+ $(PKG_BUILD_DIR)/
+ $(VERSION_SED) $(PKG_BUILD_DIR)/repositories.conf
+ $(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
+ $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
+ rm -rf \
+ $(PKG_BUILD_DIR)/target/linux/*/files{,-*} \
+ $(PKG_BUILD_DIR)/target/linux/*/patches{,-*}
+ -cp $(KERNEL_BUILD_DIR)/* $(IB_KDIR)/ # don't copy subdirectories here
+ -cp $(LINUX_DIR)/.config $(IB_LDIR)/
+ $(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(PKG_BUILD_DIR)/include/version.mk
+ find $(PKG_BUILD_DIR) -name CVS -o -name .git -o -name .svn \
+ | $(XARGS) rm -rf
+ find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
+ | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin
+ $(TAR) c -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
+
+download:
+prepare:
+compile: $(BIN_DIR)/$(IB_NAME).tar.bz2
+install: compile
+
+clean: FORCE
+ rm -rf $(PKG_BUILD_DIR) $(BIN_DIR)/$(IB_NAME).tar.bz2