aboutsummaryrefslogtreecommitdiffstats
path: root/package/px5g/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'package/px5g/.svn')
-rw-r--r--package/px5g/.svn/entries65
-rw-r--r--package/px5g/.svn/text-base/Makefile.svn-base40
2 files changed, 105 insertions, 0 deletions
diff --git a/package/px5g/.svn/entries b/package/px5g/.svn/entries
new file mode 100644
index 0000000..996f39a
--- /dev/null
+++ b/package/px5g/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/px5g
+svn://svn.openwrt.org/openwrt
+
+
+
+2010-09-30T10:48:37.964618Z
+23159
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+src
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+27a35f2227dd4baa14dd0f05c52a527c
+2010-09-30T10:48:37.964618Z
+23159
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+928
+
diff --git a/package/px5g/.svn/text-base/Makefile.svn-base b/package/px5g/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..ad4ec40
--- /dev/null
+++ b/package/px5g/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=px5g
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/px5g
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Standalone X.509 certificate generator
+ MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+endef
+
+define Package/px5g/description
+ Px5g is a tiny standalone X.509 certificate generator.
+ It suitable to create key files and certificates in DER
+ and PEM format for use with stunnel, uhttpd and others.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/px5g/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g
+endef
+
+$(eval $(call BuildPackage,px5g))