aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mklibs/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/mklibs/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'tools/mklibs/.svn')
-rw-r--r--tools/mklibs/.svn/entries68
-rw-r--r--tools/mklibs/.svn/text-base/Makefile.svn-base35
2 files changed, 103 insertions, 0 deletions
diff --git a/tools/mklibs/.svn/entries b/tools/mklibs/.svn/entries
new file mode 100644
index 0000000..235bb06
--- /dev/null
+++ b/tools/mklibs/.svn/entries
@@ -0,0 +1,68 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/mklibs
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-26T21:49:11.484409Z
+35818
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+include
+dir
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+24fc3d3c3f846389fc67d4237c7bbce3
+2013-02-26T21:49:11.484409Z
+35818
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+872
+
diff --git a/tools/mklibs/.svn/text-base/Makefile.svn-base b/tools/mklibs/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..fa0bce7
--- /dev/null
+++ b/tools/mklibs/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mklibs
+PKG_VERSION:=0.1.35
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
+PKG_MD5SUM:=3d2a4bd0bbf5ba964b0a1ecdafd1ea9a
+
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CFLAGS += -I$(CURDIR)/include
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Install
+ $(INSTALL_BIN) \
+ $(HOST_BUILD_DIR)/src/mklibs \
+ $(HOST_BUILD_DIR)/src/mklibs-copy \
+ $(HOST_BUILD_DIR)/src/mklibs-readelf/mklibs-readelf \
+ $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mklibs*
+endef
+
+$(eval $(call HostBuild))