aboutsummaryrefslogtreecommitdiffstats
path: root/tools/b43-tools/patches
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/b43-tools/patches
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'tools/b43-tools/patches')
-rw-r--r--tools/b43-tools/patches/.svn/entries130
-rw-r--r--tools/b43-tools/patches/.svn/text-base/001-fw-dirname.patch.svn-base16
-rw-r--r--tools/b43-tools/patches/.svn/text-base/002-no_libfl.patch.svn-base14
-rw-r--r--tools/b43-tools/patches/.svn/text-base/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch.svn-base27
-rw-r--r--tools/b43-tools/patches/001-fw-dirname.patch16
-rw-r--r--tools/b43-tools/patches/002-no_libfl.patch14
-rw-r--r--tools/b43-tools/patches/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch27
7 files changed, 244 insertions, 0 deletions
diff --git a/tools/b43-tools/patches/.svn/entries b/tools/b43-tools/patches/.svn/entries
new file mode 100644
index 0000000..d2d454a
--- /dev/null
+++ b/tools/b43-tools/patches/.svn/entries
@@ -0,0 +1,130 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/b43-tools/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-28T10:43:02.730422Z
+35830
+hauke
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+002-no_libfl.patch
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+80715d12b1af61c7679168155f97d4aa
+2012-10-25T16:39:38.826580Z
+33934
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+219
+
+100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+e4f61db6959bd82fb13ea3a9ec0c22ba
+2013-02-28T10:43:02.730422Z
+35830
+hauke
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+778
+
+001-fw-dirname.patch
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+9d956bcfa5498419bfb7c08e27f69821
+2012-10-08T20:15:42.151953Z
+33668
+hauke
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+352
+
diff --git a/tools/b43-tools/patches/.svn/text-base/001-fw-dirname.patch.svn-base b/tools/b43-tools/patches/.svn/text-base/001-fw-dirname.patch.svn-base
new file mode 100644
index 0000000..e9bd032
--- /dev/null
+++ b/tools/b43-tools/patches/.svn/text-base/001-fw-dirname.patch.svn-base
@@ -0,0 +1,16 @@
+--- a/fwcutter/fwcutter.c
++++ b/fwcutter/fwcutter.c
+@@ -48,13 +48,8 @@
+ #include "fwcutter.h"
+ #include "fwcutter_list.h"
+
+-#if defined(__DragonFly__) || defined(__FreeBSD__)
+-#define V3_FW_DIRNAME "v3"
+-#define V4_FW_DIRNAME "v4"
+-#else
+ #define V3_FW_DIRNAME "b43legacy"
+ #define V4_FW_DIRNAME "b43"
+-#endif
+
+ static struct cmdline_args cmdargs;
+
diff --git a/tools/b43-tools/patches/.svn/text-base/002-no_libfl.patch.svn-base b/tools/b43-tools/patches/.svn/text-base/002-no_libfl.patch.svn-base
new file mode 100644
index 0000000..2e55b08
--- /dev/null
+++ b/tools/b43-tools/patches/.svn/text-base/002-no_libfl.patch.svn-base
@@ -0,0 +1,14 @@
+--- a/assembler/main.c
++++ b/assembler/main.c
+@@ -1268,6 +1268,11 @@ static void initialize(void)
+ #endif /* YYDEBUG */
+ }
+
++int yywrap(void)
++{
++ return 1;
++}
++
+ int main(int argc, char **argv)
+ {
+ int err, res = 1;
diff --git a/tools/b43-tools/patches/.svn/text-base/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch.svn-base b/tools/b43-tools/patches/.svn/text-base/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch.svn-base
new file mode 100644
index 0000000..fc0553d
--- /dev/null
+++ b/tools/b43-tools/patches/.svn/text-base/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch.svn-base
@@ -0,0 +1,27 @@
+--- a/assembler/Makefile
++++ b/assembler/Makefile
+@@ -30,7 +30,7 @@ BIN = b43-asm.bin
+ SRCS = parser.c scanner.c main.c initvals.c util.c args.c
+
+ # YACC related CFLAGS
+-CFLAGS += -DYYSTYPE="void *" -DYYERROR_VERBOSE -DYYDEBUG -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Wno-unused
++CFLAGS += -DYYSTYPE="void *" -DYYERROR_VERBOSE -DYYDEBUG=1 -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Wno-unused
+
+ .SUFFIXES:
+ .PHONY: all install clean distclean
+diff --git a/assembler/main.c b/assembler/main.c
+index afca996..a62a15e 100644
+--- a/assembler/main.c
++++ b/assembler/main.c
+@@ -1260,7 +1260,7 @@ static void initialize(void)
+ {
+ INIT_LIST_HEAD(&infile.sl);
+ INIT_LIST_HEAD(&infile.ivals);
+-#ifdef YYDEBUG
++#if YYDEBUG
+ if (IS_INSANE_DEBUG)
+ yydebug = 1;
+ else
+--
+1.7.10.4
+
diff --git a/tools/b43-tools/patches/001-fw-dirname.patch b/tools/b43-tools/patches/001-fw-dirname.patch
new file mode 100644
index 0000000..e9bd032
--- /dev/null
+++ b/tools/b43-tools/patches/001-fw-dirname.patch
@@ -0,0 +1,16 @@
+--- a/fwcutter/fwcutter.c
++++ b/fwcutter/fwcutter.c
+@@ -48,13 +48,8 @@
+ #include "fwcutter.h"
+ #include "fwcutter_list.h"
+
+-#if defined(__DragonFly__) || defined(__FreeBSD__)
+-#define V3_FW_DIRNAME "v3"
+-#define V4_FW_DIRNAME "v4"
+-#else
+ #define V3_FW_DIRNAME "b43legacy"
+ #define V4_FW_DIRNAME "b43"
+-#endif
+
+ static struct cmdline_args cmdargs;
+
diff --git a/tools/b43-tools/patches/002-no_libfl.patch b/tools/b43-tools/patches/002-no_libfl.patch
new file mode 100644
index 0000000..2e55b08
--- /dev/null
+++ b/tools/b43-tools/patches/002-no_libfl.patch
@@ -0,0 +1,14 @@
+--- a/assembler/main.c
++++ b/assembler/main.c
+@@ -1268,6 +1268,11 @@ static void initialize(void)
+ #endif /* YYDEBUG */
+ }
+
++int yywrap(void)
++{
++ return 1;
++}
++
+ int main(int argc, char **argv)
+ {
+ int err, res = 1;
diff --git a/tools/b43-tools/patches/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch b/tools/b43-tools/patches/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch
new file mode 100644
index 0000000..fc0553d
--- /dev/null
+++ b/tools/b43-tools/patches/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch
@@ -0,0 +1,27 @@
+--- a/assembler/Makefile
++++ b/assembler/Makefile
+@@ -30,7 +30,7 @@ BIN = b43-asm.bin
+ SRCS = parser.c scanner.c main.c initvals.c util.c args.c
+
+ # YACC related CFLAGS
+-CFLAGS += -DYYSTYPE="void *" -DYYERROR_VERBOSE -DYYDEBUG -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Wno-unused
++CFLAGS += -DYYSTYPE="void *" -DYYERROR_VERBOSE -DYYDEBUG=1 -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Wno-unused
+
+ .SUFFIXES:
+ .PHONY: all install clean distclean
+diff --git a/assembler/main.c b/assembler/main.c
+index afca996..a62a15e 100644
+--- a/assembler/main.c
++++ b/assembler/main.c
+@@ -1260,7 +1260,7 @@ static void initialize(void)
+ {
+ INIT_LIST_HEAD(&infile.sl);
+ INIT_LIST_HEAD(&infile.ivals);
+-#ifdef YYDEBUG
++#if YYDEBUG
+ if (IS_INSANE_DEBUG)
+ yydebug = 1;
+ else
+--
+1.7.10.4
+