aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /toolchain/eglibc/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'toolchain/eglibc/.svn')
-rw-r--r--toolchain/eglibc/.svn/entries176
-rw-r--r--toolchain/eglibc/.svn/text-base/Config.in.svn-base33
-rw-r--r--toolchain/eglibc/.svn/text-base/Config.version.svn-base7
-rw-r--r--toolchain/eglibc/.svn/text-base/Makefile.svn-base27
-rw-r--r--toolchain/eglibc/.svn/text-base/common.mk.svn-base95
5 files changed, 338 insertions, 0 deletions
diff --git a/toolchain/eglibc/.svn/entries b/toolchain/eglibc/.svn/entries
new file mode 100644
index 0000000..afcce02
--- /dev/null
+++ b/toolchain/eglibc/.svn/entries
@@ -0,0 +1,176 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain/eglibc
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-07T17:34:53.089162Z
+35515
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+include
+dir
+
+config
+dir
+
+patches
+dir
+
+Config.version
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+59fbec344cbcf2f5788e2cadbe26cb9a
+2013-02-07T17:34:53.089162Z
+35515
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+186
+
+Config.in
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+bbbf78c9365d35e473018a48d0b14674
+2013-02-07T17:34:53.089162Z
+35515
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+724
+
+headers
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+c8d1232cc974afeabbf3eb2ecb8de644
+2012-10-31T00:23:55.160401Z
+34025
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+589
+
+common.mk
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+56aaa42e6215fe3e1a52466ea8917bd2
+2013-02-07T17:34:53.089162Z
+35515
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2931
+
diff --git a/toolchain/eglibc/.svn/text-base/Config.in.svn-base b/toolchain/eglibc/.svn/text-base/Config.in.svn-base
new file mode 100644
index 0000000..11f9abe
--- /dev/null
+++ b/toolchain/eglibc/.svn/text-base/Config.in.svn-base
@@ -0,0 +1,33 @@
+choice
+ prompt "eglibc version"
+ depends on TOOLCHAINOPTS && USE_EGLIBC
+ default EGLIBC_VERSION_2_15
+ help
+ Select the version of eglibc you wish to use.
+
+ config EGLIBC_VERSION_2_15
+ bool "eglibc 2.15"
+ depends !GCC_VERSION_LLVM
+
+ config EGLIBC_VERSION_2_16
+ bool "eglibc 2.16"
+ depends !GCC_VERSION_LLVM
+
+ config EGLIBC_VERSION_2_17
+ bool "eglibc 2.17"
+ depends !GCC_VERSION_LLVM
+
+endchoice
+
+config EGLIBC_REVISION
+ string
+ depends on TOOLCHAINOPTS && USE_EGLIBC
+ default "18909" if EGLIBC_VERSION_2_15
+ default "21110" if EGLIBC_VERSION_2_16
+ default "22243" if EGLIBC_VERSION_2_17
+ default ""
+
+menu "eglibc configuration"
+ depends on TOOLCHAINOPTS && USE_EGLIBC
+ source toolchain/eglibc/config/Config.in
+endmenu
diff --git a/toolchain/eglibc/.svn/text-base/Config.version.svn-base b/toolchain/eglibc/.svn/text-base/Config.version.svn-base
new file mode 100644
index 0000000..92ba3e6
--- /dev/null
+++ b/toolchain/eglibc/.svn/text-base/Config.version.svn-base
@@ -0,0 +1,7 @@
+config EGLIBC_VERSION
+ string
+ depends on USE_EGLIBC
+ default "2.15" if EGLIBC_VERSION_2_15
+ default "2.16" if EGLIBC_VERSION_2_16
+ default "2.17" if EGLIBC_VERSION_2_17
+ default "2.15"
diff --git a/toolchain/eglibc/.svn/text-base/Makefile.svn-base b/toolchain/eglibc/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..429ed30
--- /dev/null
+++ b/toolchain/eglibc/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,27 @@
+PATH_PREFIX := .
+VARIANT:=final
+HOST_BUILD_PARALLEL:=1
+
+include ./common.mk
+
+define Host/Compile
+ $(MAKE) -C $(CUR_BUILD_DIR) all PARALLELMFLAGS="$(HOST_JOBS)"
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ install_root="$(TOOLCHAIN_DIR)" \
+ install
+ ( cd $(TOOLCHAIN_DIR) ; \
+ for d in lib usr/lib ; do \
+ for f in libc.so libpthread.so libgcc_s.so ; do \
+ if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
+ $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
+ fi \
+ done \
+ done \
+ )
+endef
+
+$(eval $(call HostBuild))
diff --git a/toolchain/eglibc/.svn/text-base/common.mk.svn-base b/toolchain/eglibc/.svn/text-base/common.mk.svn-base
new file mode 100644
index 0000000..483f57d
--- /dev/null
+++ b/toolchain/eglibc/.svn/text-base/common.mk.svn-base
@@ -0,0 +1,95 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=eglibc
+PKG_VERSION:=$(call qstrip,$(CONFIG_EGLIBC_VERSION))
+PKG_REVISION:=$(call qstrip,$(CONFIG_EGLIBC_REVISION))
+
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REVISION)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
+
+ifneq ($(CONFIG_EGLIBC_VERSION_2_15),)
+ PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_15
+endif
+ifneq ($(CONFIG_EGLIBC_VERSION_2_16),)
+ PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_16
+endif
+ifneq ($(CONFIG_EGLIBC_VERSION_2_17),)
+ PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_17
+endif
+
+PATCH_DIR:=$(PATH_PREFIX)/patches/$(PKG_VERSION)
+
+HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_SOURCE_SUBDIR)
+CUR_BUILD_DIR:=$(HOST_BUILD_DIR)-$(VARIANT)
+
+include $(INCLUDE_DIR)/toolchain-build.mk
+
+HOST_STAMP_PREPARED:=$(HOST_BUILD_DIR)/.prepared
+HOST_STAMP_CONFIGURED:=$(CUR_BUILD_DIR)/.configured
+HOST_STAMP_BUILT:=$(CUR_BUILD_DIR)/.built
+HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.eglibc_$(VARIANT)_installed
+
+
+EGLIBC_CONFIGURE:= \
+ BUILD_CC="$(HOSTCC)" \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ libc_cv_slibdir="/lib" \
+ use_ldconfig=no \
+ $(HOST_BUILD_DIR)/libc/configure \
+ --prefix= \
+ --build=$(GNU_HOST_NAME) \
+ --host=$(REAL_GNU_TARGET_NAME) \
+ --with-headers=$(TOOLCHAIN_DIR)/include \
+ --disable-profile \
+ --without-gd \
+ --without-cvs \
+ --enable-add-ons \
+ --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp
+
+export libc_cv_ssp=no
+export ac_cv_header_cpuid_h=yes
+export HOST_CFLAGS := $(HOST_CFLAGS) -idirafter $(CURDIR)/$(PATH_PREFIX)/include
+
+define Host/SetToolchainInfo
+ $(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
+ $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.eglibc.org/,' $(TOOLCHAIN_DIR)/info.mk
+ $(SED) 's,^\(LIBC_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
+ $(SED) 's,^\(LIBC_SO_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
+endef
+
+define Host/Configure
+ [ -f $(HOST_BUILD_DIR)/.autoconf ] || { \
+ cd $(HOST_BUILD_DIR)/libc; \
+ autoconf --force && \
+ touch $(HOST_BUILD_DIR)/.autoconf; \
+ }
+ mkdir -p $(CUR_BUILD_DIR)
+ grep 'CONFIG_EGLIBC_OPTION_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_EGLIBC_\\(.*\\),\\1\\2,g" > $(CUR_BUILD_DIR)/option-groups.config
+ ( cd $(CUR_BUILD_DIR); rm -f config.cache; \
+ $(EGLIBC_CONFIGURE) \
+ );
+endef
+
+define Host/Prepare
+ $(call Host/Prepare/Default)
+ ln -snf $(PKG_SOURCE_SUBDIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+ $(SED) 's,y,n,' $(HOST_BUILD_DIR)/libc/option-groups.defaults
+ifneq ($(CONFIG_EGLIBC_VERSION_2_17),y)
+ ln -sf ../ports $(HOST_BUILD_DIR)/libc/
+endif
+endef
+
+define Host/Clean
+ rm -rf $(CUR_BUILD_DIR)* \
+ $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev \
+ $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+endef