aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap4/image
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/omap4/image
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/omap4/image')
-rw-r--r--target/linux/omap4/image/.svn/entries96
-rw-r--r--target/linux/omap4/image/.svn/text-base/Makefile.svn-base36
-rw-r--r--target/linux/omap4/image/.svn/text-base/boot.script.svn-base3
-rw-r--r--target/linux/omap4/image/Makefile36
-rw-r--r--target/linux/omap4/image/boot.script3
5 files changed, 174 insertions, 0 deletions
diff --git a/target/linux/omap4/image/.svn/entries b/target/linux/omap4/image/.svn/entries
new file mode 100644
index 0000000..48b7365
--- /dev/null
+++ b/target/linux/omap4/image/.svn/entries
@@ -0,0 +1,96 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/omap4/image
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-01-14T23:02:56.596337Z
+29753
+kaloz
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+boot.script
+file
+
+
+
+
+2013-03-17T12:13:05.000000Z
+e724bc77838fd20c00b2e14260ab4cb5
+2012-01-14T23:02:56.596337Z
+29753
+kaloz
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+183
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:05.000000Z
+f80d25c9bb8266b432cdc072f472f944
+2012-01-14T23:02:56.596337Z
+29753
+kaloz
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+984
+
diff --git a/target/linux/omap4/image/.svn/text-base/Makefile.svn-base b/target/linux/omap4/image/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..5123c3a
--- /dev/null
+++ b/target/linux/omap4/image/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'Boot Image' -d boot.script $(BIN_DIR)/boot.scr
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/omap4/image/.svn/text-base/boot.script.svn-base b/target/linux/omap4/image/.svn/text-base/boot.script.svn-base
new file mode 100644
index 0000000..521f438
--- /dev/null
+++ b/target/linux/omap4/image/.svn/text-base/boot.script.svn-base
@@ -0,0 +1,3 @@
+fatload mmc 0:1 0x80000000 openwrt-omap4-uImage
+setenv bootargs vram=32M fixrtc mem=1G@0x80000000 root=/dev/mmcblk0p2 rootfstype=ext4 console=ttyO2,115200n8 rootwait
+bootm 0x80000000
diff --git a/target/linux/omap4/image/Makefile b/target/linux/omap4/image/Makefile
new file mode 100644
index 0000000..5123c3a
--- /dev/null
+++ b/target/linux/omap4/image/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'Boot Image' -d boot.script $(BIN_DIR)/boot.scr
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/omap4/image/boot.script b/target/linux/omap4/image/boot.script
new file mode 100644
index 0000000..521f438
--- /dev/null
+++ b/target/linux/omap4/image/boot.script
@@ -0,0 +1,3 @@
+fatload mmc 0:1 0x80000000 openwrt-omap4-uImage
+setenv bootargs vram=32M fixrtc mem=1G@0x80000000 root=/dev/mmcblk0p2 rootfstype=ext4 console=ttyO2,115200n8 rootwait
+bootm 0x80000000