aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/profiles
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/omap24xx/profiles
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/omap24xx/profiles')
-rw-r--r--target/linux/omap24xx/profiles/.svn/entries96
-rw-r--r--target/linux/omap24xx/profiles/.svn/text-base/100-n810.mk.svn-base31
-rw-r--r--target/linux/omap24xx/profiles/.svn/text-base/110-n810-gui.mk.svn-base22
-rw-r--r--target/linux/omap24xx/profiles/100-n810.mk31
-rw-r--r--target/linux/omap24xx/profiles/110-n810-gui.mk22
5 files changed, 202 insertions, 0 deletions
diff --git a/target/linux/omap24xx/profiles/.svn/entries b/target/linux/omap24xx/profiles/.svn/entries
new file mode 100644
index 0000000..95c8605
--- /dev/null
+++ b/target/linux/omap24xx/profiles/.svn/entries
@@ -0,0 +1,96 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/omap24xx/profiles
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-09-28T21:54:31.333898Z
+33593
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+100-n810.mk
+file
+
+
+
+
+2013-03-17T12:13:06.000000Z
+0afc67166e95de72f8eac59b94c663b8
+2012-09-28T21:54:31.333898Z
+33593
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+785
+
+110-n810-gui.mk
+file
+
+
+
+
+2013-03-17T12:13:06.000000Z
+7d7c8ab20de54ad345ab3f4abd60c810
+2011-11-16T19:03:23.381780Z
+29195
+mb
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+548
+
diff --git a/target/linux/omap24xx/profiles/.svn/text-base/100-n810.mk.svn-base b/target/linux/omap24xx/profiles/.svn/text-base/100-n810.mk.svn-base
new file mode 100644
index 0000000..36f3086
--- /dev/null
+++ b/target/linux/omap24xx/profiles/.svn/text-base/100-n810.mk.svn-base
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/n810-base
+ NAME:=Nokia n810 (base)
+ PACKAGES:= \
+ block-mount \
+ gpsd \
+ ip iw kmod-p54-spi wpa-supplicant \
+ dnsmasq dropbear \
+ pwrtray-backend \
+ kmod-fs-vfat kmod-fs-msdos \
+ kmod-input-evdev \
+ kmod-leds-gpio \
+ kmod-usb-tahvo kmod-usb-eth-gadget \
+ kmod-usb-net kmod-usb-net-cdc-ether kmod-usb-net-pegasus kmod-usb-net-rndis \
+ kmod-usb-storage kmod-usb-hid \
+ kmod-bluetooth kmod-bluetooth-hci-h4p bluez-utils bluez-hcidump \
+ kmod-n810bm maemo-kexec calvaria \
+ schedtool
+endef
+
+define Profile/n810-base/Description
+ Minimal package set for Nokia n810 hardware.
+endef
+$(eval $(call Profile,n810-base))
+
diff --git a/target/linux/omap24xx/profiles/.svn/text-base/110-n810-gui.mk.svn-base b/target/linux/omap24xx/profiles/.svn/text-base/110-n810-gui.mk.svn-base
new file mode 100644
index 0000000..9c3c5d0
--- /dev/null
+++ b/target/linux/omap24xx/profiles/.svn/text-base/110-n810-gui.mk.svn-base
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/n810-gui
+ $(call Profile/n810-base)
+ NAME:=Nokia n810 (GUI)
+ PACKAGES+= \
+ xserver-xorg xinit xauth xkeyboard-config xkbdata xterm \
+ xf86-video-omapfb xf86-input-tslib xf86-input-evdev \
+ openbox tint2 matchbox-keyboard \
+ pwrtray
+endef
+
+define Profile/n810-gui/Description
+ Graphical user interface package set for Nokia n810 hardware.
+endef
+$(eval $(call Profile,n810-gui))
+
diff --git a/target/linux/omap24xx/profiles/100-n810.mk b/target/linux/omap24xx/profiles/100-n810.mk
new file mode 100644
index 0000000..36f3086
--- /dev/null
+++ b/target/linux/omap24xx/profiles/100-n810.mk
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/n810-base
+ NAME:=Nokia n810 (base)
+ PACKAGES:= \
+ block-mount \
+ gpsd \
+ ip iw kmod-p54-spi wpa-supplicant \
+ dnsmasq dropbear \
+ pwrtray-backend \
+ kmod-fs-vfat kmod-fs-msdos \
+ kmod-input-evdev \
+ kmod-leds-gpio \
+ kmod-usb-tahvo kmod-usb-eth-gadget \
+ kmod-usb-net kmod-usb-net-cdc-ether kmod-usb-net-pegasus kmod-usb-net-rndis \
+ kmod-usb-storage kmod-usb-hid \
+ kmod-bluetooth kmod-bluetooth-hci-h4p bluez-utils bluez-hcidump \
+ kmod-n810bm maemo-kexec calvaria \
+ schedtool
+endef
+
+define Profile/n810-base/Description
+ Minimal package set for Nokia n810 hardware.
+endef
+$(eval $(call Profile,n810-base))
+
diff --git a/target/linux/omap24xx/profiles/110-n810-gui.mk b/target/linux/omap24xx/profiles/110-n810-gui.mk
new file mode 100644
index 0000000..9c3c5d0
--- /dev/null
+++ b/target/linux/omap24xx/profiles/110-n810-gui.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/n810-gui
+ $(call Profile/n810-base)
+ NAME:=Nokia n810 (GUI)
+ PACKAGES+= \
+ xserver-xorg xinit xauth xkeyboard-config xkbdata xterm \
+ xf86-video-omapfb xf86-input-tslib xf86-input-evdev \
+ openbox tint2 matchbox-keyboard \
+ pwrtray
+endef
+
+define Profile/n810-gui/Description
+ Graphical user interface package set for Nokia n810 hardware.
+endef
+$(eval $(call Profile,n810-gui))
+