aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/Makefile
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/omap24xx/Makefile
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/omap24xx/Makefile')
-rw-r--r--target/linux/omap24xx/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
new file mode 100644
index 0000000..7a7e4d8
--- /dev/null
+++ b/target/linux/omap24xx/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=omap24xx
+BOARDNAME:=TI OMAP24xx
+MAINTAINER:=Michael Buesch <m@bues.ch>
+FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio broken
+
+LINUX_VERSION:=3.3.8
+
+define Target/Description
+ TI OMAP-24xx
+endef
+
+CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s -fno-caller-saves
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))