aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/falcon
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/lantiq/falcon
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/lantiq/falcon')
-rw-r--r--target/linux/lantiq/falcon/.svn/entries99
-rw-r--r--target/linux/lantiq/falcon/.svn/text-base/config-default.svn-base24
-rw-r--r--target/linux/lantiq/falcon/.svn/text-base/target.mk.svn-base13
-rw-r--r--target/linux/lantiq/falcon/config-default24
-rw-r--r--target/linux/lantiq/falcon/profiles/.svn/entries62
-rw-r--r--target/linux/lantiq/falcon/profiles/.svn/text-base/lantiq.mk.svn-base19
-rw-r--r--target/linux/lantiq/falcon/profiles/lantiq.mk19
-rw-r--r--target/linux/lantiq/falcon/target.mk13
8 files changed, 273 insertions, 0 deletions
diff --git a/target/linux/lantiq/falcon/.svn/entries b/target/linux/lantiq/falcon/.svn/entries
new file mode 100644
index 0000000..e53f47a
--- /dev/null
+++ b/target/linux/lantiq/falcon/.svn/entries
@@ -0,0 +1,99 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/lantiq/falcon
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-12-16T10:03:23.828751Z
+34713
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+profiles
+dir
+
+config-default
+file
+
+
+
+
+2013-03-17T12:12:37.000000Z
+a2626fc719c80db09decda83b79a6b8c
+2012-12-16T10:03:23.828751Z
+34713
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+597
+
+target.mk
+file
+
+
+
+
+2013-03-17T12:12:37.000000Z
+0632e0ebfdae72044af7b5b1122ccc89
+2011-11-11T21:59:11.802499Z
+28962
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+351
+
diff --git a/target/linux/lantiq/falcon/.svn/text-base/config-default.svn-base b/target/linux/lantiq/falcon/.svn/text-base/config-default.svn-base
new file mode 100644
index 0000000..fef4015
--- /dev/null
+++ b/target/linux/lantiq/falcon/.svn/text-base/config-default.svn-base
@@ -0,0 +1,24 @@
+CONFIG_GPIO_FALCON=y
+CONFIG_GPIO_GENERIC=y
+CONFIG_I2C=y
+CONFIG_I2C_BOARDINFO=y
+CONFIG_I2C_CHARDEV=y
+# CONFIG_I2C_LANTIQ is not set
+CONFIG_M25PXX_USE_FAST_READ=y
+CONFIG_MTD_M25P80=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_FALCON=y
+CONFIG_MTD_NAND_PLATFORM=y
+# CONFIG_MTD_SM_COMMON is not set
+CONFIG_OF_I2C=y
+CONFIG_PINCTRL_FALCON=y
+CONFIG_SOC_FALCON=y
+# CONFIG_SOC_TYPE_XWAY is not set
+# CONFIG_SOC_XWAY is not set
+CONFIG_SPI=y
+CONFIG_SPI_FALCON=y
+CONFIG_SPI_MASTER=y
+# CONFIG_USB_ARCH_HAS_EHCI is not set
+# CONFIG_USB_ARCH_HAS_OHCI is not set
+# CONFIG_USB_ARCH_HAS_XHCI is not set
diff --git a/target/linux/lantiq/falcon/.svn/text-base/target.mk.svn-base b/target/linux/lantiq/falcon/.svn/text-base/target.mk.svn-base
new file mode 100644
index 0000000..eec3f51
--- /dev/null
+++ b/target/linux/lantiq/falcon/.svn/text-base/target.mk.svn-base
@@ -0,0 +1,13 @@
+ARCH:=mips
+SUBTARGET:=falcon
+BOARDNAME:=Falcon
+FEATURES:=squashfs jffs2
+DEVICE_TYPE:=other
+
+DEFAULT_PACKAGES+= kmod-ifxos gpon-base-files kmod-leds-gpio kmod-ledtrig-heartbeat \
+ kmod-gpon-optic-drv gpon-optic-drv kmod-gpon-onu-drv gpon-onu-drv \
+ gpon-pe-firmware gpon-omci-api gpon-omci-onu gpon-luci
+
+define Target/Description
+ Lantiq Falcon
+endef
diff --git a/target/linux/lantiq/falcon/config-default b/target/linux/lantiq/falcon/config-default
new file mode 100644
index 0000000..fef4015
--- /dev/null
+++ b/target/linux/lantiq/falcon/config-default
@@ -0,0 +1,24 @@
+CONFIG_GPIO_FALCON=y
+CONFIG_GPIO_GENERIC=y
+CONFIG_I2C=y
+CONFIG_I2C_BOARDINFO=y
+CONFIG_I2C_CHARDEV=y
+# CONFIG_I2C_LANTIQ is not set
+CONFIG_M25PXX_USE_FAST_READ=y
+CONFIG_MTD_M25P80=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_FALCON=y
+CONFIG_MTD_NAND_PLATFORM=y
+# CONFIG_MTD_SM_COMMON is not set
+CONFIG_OF_I2C=y
+CONFIG_PINCTRL_FALCON=y
+CONFIG_SOC_FALCON=y
+# CONFIG_SOC_TYPE_XWAY is not set
+# CONFIG_SOC_XWAY is not set
+CONFIG_SPI=y
+CONFIG_SPI_FALCON=y
+CONFIG_SPI_MASTER=y
+# CONFIG_USB_ARCH_HAS_EHCI is not set
+# CONFIG_USB_ARCH_HAS_OHCI is not set
+# CONFIG_USB_ARCH_HAS_XHCI is not set
diff --git a/target/linux/lantiq/falcon/profiles/.svn/entries b/target/linux/lantiq/falcon/profiles/.svn/entries
new file mode 100644
index 0000000..591b050
--- /dev/null
+++ b/target/linux/lantiq/falcon/profiles/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/lantiq/falcon/profiles
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-12-16T10:03:23.828751Z
+34713
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+lantiq.mk
+file
+
+
+
+
+2013-03-17T12:12:37.000000Z
+0d30678c538ccb9dd84bb9ca33712f5f
+2012-12-16T10:03:23.828751Z
+34713
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+518
+
diff --git a/target/linux/lantiq/falcon/profiles/.svn/text-base/lantiq.mk.svn-base b/target/linux/lantiq/falcon/profiles/.svn/text-base/lantiq.mk.svn-base
new file mode 100644
index 0000000..ab60ff5
--- /dev/null
+++ b/target/linux/lantiq/falcon/profiles/.svn/text-base/lantiq.mk.svn-base
@@ -0,0 +1,19 @@
+define Profile/EASY98000NOR
+ NAME:=Lantiq Falcon - EASY98000NOR
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+$(eval $(call Profile,EASY98000NOR))
+
+define Profile/EASY98000SFLASH
+ NAME:=Lantiq Falcon - EASY98000SFLASH
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+$(eval $(call Profile,EASY98000SFLASH))
diff --git a/target/linux/lantiq/falcon/profiles/lantiq.mk b/target/linux/lantiq/falcon/profiles/lantiq.mk
new file mode 100644
index 0000000..ab60ff5
--- /dev/null
+++ b/target/linux/lantiq/falcon/profiles/lantiq.mk
@@ -0,0 +1,19 @@
+define Profile/EASY98000NOR
+ NAME:=Lantiq Falcon - EASY98000NOR
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+$(eval $(call Profile,EASY98000NOR))
+
+define Profile/EASY98000SFLASH
+ NAME:=Lantiq Falcon - EASY98000SFLASH
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+$(eval $(call Profile,EASY98000SFLASH))
diff --git a/target/linux/lantiq/falcon/target.mk b/target/linux/lantiq/falcon/target.mk
new file mode 100644
index 0000000..eec3f51
--- /dev/null
+++ b/target/linux/lantiq/falcon/target.mk
@@ -0,0 +1,13 @@
+ARCH:=mips
+SUBTARGET:=falcon
+BOARDNAME:=Falcon
+FEATURES:=squashfs jffs2
+DEVICE_TYPE:=other
+
+DEFAULT_PACKAGES+= kmod-ifxos gpon-base-files kmod-leds-gpio kmod-ledtrig-heartbeat \
+ kmod-gpon-optic-drv gpon-optic-drv kmod-gpon-onu-drv gpon-onu-drv \
+ gpon-pe-firmware gpon-omci-api gpon-omci-onu gpon-luci
+
+define Target/Description
+ Lantiq Falcon
+endef