aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/Makefile
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/lantiq/Makefile
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/lantiq/Makefile')
-rw-r--r--target/linux/lantiq/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
new file mode 100644
index 0000000..706dc66
--- /dev/null
+++ b/target/linux/lantiq/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2007-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+BOARD:=lantiq
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
+FEATURES:=squashfs jffs2
+SUBTARGETS=xway ase falcon
+
+LINUX_VERSION:=3.8.3
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+
+define Target/Description
+ Build firmware images for Lantiq SoC
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))