aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/Makefile
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/brcm47xx/Makefile
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/brcm47xx/Makefile')
-rw-r--r--target/linux/brcm47xx/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
new file mode 100644
index 0000000..a202bd6
--- /dev/null
+++ b/target/linux/brcm47xx/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=brcm47xx
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs usb pcmcia
+
+LINUX_VERSION:=3.6.11
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
+
+define Target/Description
+ Build firmware images for Broadcom based routers
+ (e.g. Netgear WGT634U)
+endef
+
+$(eval $(call BuildTarget))