aboutsummaryrefslogtreecommitdiffstats
path: root/package/zram-swap/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /package/zram-swap/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'package/zram-swap/.svn')
-rw-r--r--package/zram-swap/.svn/entries65
-rw-r--r--package/zram-swap/.svn/text-base/Makefile.svn-base46
2 files changed, 111 insertions, 0 deletions
diff --git a/package/zram-swap/.svn/entries b/package/zram-swap/.svn/entries
new file mode 100644
index 0000000..7a5b045
--- /dev/null
+++ b/package/zram-swap/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/zram-swap
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-01-07T12:01:11.988661Z
+35033
+acinonyx
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+files
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:10.000000Z
+24f86ea544fd4f4e5f7f581dfa5ce78f
+2013-01-07T12:01:11.988661Z
+35033
+acinonyx
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+953
+
diff --git a/package/zram-swap/.svn/text-base/Makefile.svn-base b/package/zram-swap/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..bded5f3
--- /dev/null
+++ b/package/zram-swap/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=zram-swap
+PKG_VERSION:=1
+PKG_RELEASE:=2
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/zram-swap
+ SECTION:=utils
+ CATEGORY:=Base system
+ DEPENDS:=+kmod-zram +!(BUSYBOX_CONFIG_MKSWAP&&BUSYBOX_CONFIG_SWAPONOFF):swap-utils
+ TITLE:=ZRAM swap scripts
+ PKGARCH:=all
+endef
+
+define Package/zram-swap/description
+ A script to activate swaping on a compressed zram partition. This
+ could be used to increase the available memory, by using compressed
+ memory.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/zram-swap/install
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/zram.init $(1)/etc/init.d/zram
+endef
+
+$(eval $(call BuildPackage,zram-swap))