aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7620.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d7acb1b8f9..d6da803b52 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -8,8 +8,9 @@ define Build/tplink-header
endef
define Build/pad-kernel-ex2700
- dd if=$@ of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
- && cat ex2700-fakeroot.uImage >> $@.new && mv $@.new $@
+ dd if=/dev/zero of=$@.pad bs=64 count=1 && cat $@ $@.pad \
+ | dd of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
+ && cat ex2700-fakeroot.uImage >> $@.new && rm $@.pad && mv $@.new $@
endef
define Build/netgear-header