aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/package/openwrt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/package/openwrt/Makefile')
-rw-r--r--target/linux/package/openwrt/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/package/openwrt/Makefile b/target/linux/package/openwrt/Makefile
index 45b33b8869..6fb20d6229 100644
--- a/target/linux/package/openwrt/Makefile
+++ b/target/linux/package/openwrt/Makefile
@@ -36,12 +36,13 @@ $(IDIR_OPENWRT):
$(SED) s,base-files-arch,base-files-$(BOARD),g $(IDIR_OPENWRT)/CONTROL/control
$(IPKG_OPENWRT): $(IDIR_OPENWRT)
- mkdir -p $(IDIR_OPENWRT)/etc
- cp files/network.overrides.$(BOARD) $(IDIR_OPENWRT)/etc/network.overrides
+ mkdir -p $(IDIR_OPENWRT)/etc/init.d
+ [ -f files/network.overrides.$(BOARD) ] && cp files/network.overrides.$(BOARD) $(IDIR_OPENWRT)/etc/network.overrides
+ [ -f files/S05nvram.$(BOARD) ] && install -m0755 files/S05nvram.$(BOARD) $(IDIR_OPENWRT)/etc/init.d/S05nvram
$(RSTRIP) $(IDIR_OPENWRT)
$(IPKG_BUILD) $(IDIR_OPENWRT) $(PACKAGE_DIR)
-install: $(IPKG_OPENWRT)
+install: compile
$(IPKG) install $(IPKG_OPENWRT)
compile: install-dev $(IPKG_OPENWRT)
install-dev: