aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/patches/200-gateway_7001.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/patches/200-gateway_7001.patch')
-rw-r--r--target/linux/ixp4xx/patches/200-gateway_7001.patch256
1 files changed, 0 insertions, 256 deletions
diff --git a/target/linux/ixp4xx/patches/200-gateway_7001.patch b/target/linux/ixp4xx/patches/200-gateway_7001.patch
deleted file mode 100644
index 509b24a248..0000000000
--- a/target/linux/ixp4xx/patches/200-gateway_7001.patch
+++ /dev/null
@@ -1,256 +0,0 @@
-Index: linux-2.6.21.7/arch/arm/boot/compressed/head-xscale.S
-===================================================================
---- linux-2.6.21.7.orig/arch/arm/boot/compressed/head-xscale.S
-+++ linux-2.6.21.7/arch/arm/boot/compressed/head-xscale.S
-@@ -46,6 +46,11 @@ __XScale_start:
- orr r7, r7, #(MACH_TYPE_GTWX5715 & 0xff00)
- #endif
-
-+#ifdef CONFIG_MACH_GATEWAY7001
-+ mov r7, #(MACH_TYPE_GATEWAY7001 & 0xff)
-+ orr r7, r7, #(MACH_TYPE_GATEWAY7001 & 0xff00)
-+#endif
-+
- #ifdef CONFIG_ARCH_IXP2000
- mov r1, #-1
- mov r0, #0xd6000000
-Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/gateway7001-pci.c
-===================================================================
---- /dev/null
-+++ linux-2.6.21.7/arch/arm/mach-ixp4xx/gateway7001-pci.c
-@@ -0,0 +1,68 @@
-+/*
-+ * arch/arch/mach-ixp4xx/gateway7001-pci.c
-+ *
-+ * PCI setup routines for Gateway 7001
-+ *
-+ * Copyright (C) 2006 Imre Kaloz <kaloz@openwrt.org>
-+ *
-+ * based on coyote-pci.c:
-+ * Copyright (C) 2002 Jungo Software Technologies.
-+ * Copyright (C) 2003 MontaVista Softwrae, Inc.
-+ *
-+ * Maintainer: Imre Kaloz <kaloz@openwrt.org>
-+ *
-+ * This program is free software; you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License version 2 as
-+ * published by the Free Software Foundation.
-+ *
-+ */
-+
-+#include <linux/kernel.h>
-+#include <linux/pci.h>
-+#include <linux/init.h>
-+#include <linux/irq.h>
-+
-+#include <asm/mach-types.h>
-+#include <asm/hardware.h>
-+#include <asm/irq.h>
-+
-+#include <asm/mach/pci.h>
-+
-+extern void ixp4xx_pci_preinit(void);
-+extern int ixp4xx_setup(int nr, struct pci_sys_data *sys);
-+extern struct pci_bus *ixp4xx_scan_bus(int nr, struct pci_sys_data *sys);
-+
-+void __init gateway7001_pci_preinit(void)
-+{
-+ set_irq_type(IRQ_IXP4XX_GPIO10, IRQT_LOW);
-+ set_irq_type(IRQ_IXP4XX_GPIO11, IRQT_LOW);
-+
-+ ixp4xx_pci_preinit();
-+}
-+
-+static int __init gateway7001_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
-+{
-+ if (slot == 1)
-+ return IRQ_IXP4XX_GPIO11;
-+ else if (slot == 2)
-+ return IRQ_IXP4XX_GPIO10;
-+ else return -1;
-+}
-+
-+struct hw_pci gateway7001_pci __initdata = {
-+ .nr_controllers = 1,
-+ .preinit = gateway7001_pci_preinit,
-+ .swizzle = pci_std_swizzle,
-+ .setup = ixp4xx_setup,
-+ .scan = ixp4xx_scan_bus,
-+ .map_irq = gateway7001_map_irq,
-+};
-+
-+int __init gateway7001_pci_init(void)
-+{
-+ if (machine_is_gateway7001())
-+ pci_common_init(&gateway7001_pci);
-+ return 0;
-+}
-+
-+subsys_initcall(gateway7001_pci_init);
-Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/gateway7001-setup.c
-===================================================================
---- /dev/null
-+++ linux-2.6.21.7/arch/arm/mach-ixp4xx/gateway7001-setup.c
-@@ -0,0 +1,108 @@
-+/*
-+ * arch/arm/mach-ixp4xx/gateway7001-setup.c
-+ *
-+ * Board setup for the Gateway 7001 board
-+ *
-+ * Copyright (C) 2006 Imre Kaloz <Kaloz@openwrt.org>
-+ *
-+ * based on coyote-setup.c:
-+ * Copyright (C) 2003-2005 MontaVista Software, Inc.
-+ *
-+ * Author: Imre Kaloz <Kaloz@openwrt.org>
-+ */
-+
-+#include <linux/kernel.h>
-+#include <linux/init.h>
-+#include <linux/device.h>
-+#include <linux/serial.h>
-+#include <linux/tty.h>
-+#include <linux/serial_8250.h>
-+#include <linux/slab.h>
-+
-+#include <asm/types.h>
-+#include <asm/setup.h>
-+#include <asm/memory.h>
-+#include <asm/hardware.h>
-+#include <asm/irq.h>
-+#include <asm/mach-types.h>
-+#include <asm/mach/arch.h>
-+#include <asm/mach/flash.h>
-+
-+static struct flash_platform_data gateway7001_flash_data = {
-+ .map_name = "cfi_probe",
-+ .width = 2,
-+};
-+
-+static struct resource gateway7001_flash_resource = {
-+ .flags = IORESOURCE_MEM,
-+};
-+
-+static struct platform_device gateway7001_flash = {
-+ .name = "IXP4XX-Flash",
-+ .id = 0,
-+ .dev = {
-+ .platform_data = &gateway7001_flash_data,
-+ },
-+ .num_resources = 1,
-+ .resource = &gateway7001_flash_resource,
-+};
-+
-+static struct resource gateway7001_uart_resource = {
-+ .start = IXP4XX_UART2_BASE_PHYS,
-+ .end = IXP4XX_UART2_BASE_PHYS + 0x0fff,
-+ .flags = IORESOURCE_MEM,
-+};
-+
-+static struct plat_serial8250_port gateway7001_uart_data[] = {
-+ {
-+ .mapbase = IXP4XX_UART2_BASE_PHYS,
-+ .membase = (char *)IXP4XX_UART2_BASE_VIRT + REG_OFFSET,
-+ .irq = IRQ_IXP4XX_UART2,
-+ .flags = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
-+ .iotype = UPIO_MEM,
-+ .regshift = 2,
-+ .uartclk = IXP4XX_UART_XTAL,
-+ },
-+ { },
-+};
-+
-+static struct platform_device gateway7001_uart = {
-+ .name = "serial8250",
-+ .id = PLAT8250_DEV_PLATFORM,
-+ .dev = {
-+ .platform_data = gateway7001_uart_data,
-+ },
-+ .num_resources = 1,
-+ .resource = &gateway7001_uart_resource,
-+};
-+
-+static struct platform_device *gateway7001_devices[] __initdata = {
-+ &gateway7001_flash,
-+ &gateway7001_uart
-+};
-+
-+static void __init gateway7001_init(void)
-+{
-+ ixp4xx_sys_init();
-+
-+ gateway7001_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
-+ gateway7001_flash_resource.end = IXP4XX_EXP_BUS_BASE(0) + SZ_32M - 1;
-+
-+ *IXP4XX_EXP_CS0 |= IXP4XX_FLASH_WRITABLE;
-+ *IXP4XX_EXP_CS1 = *IXP4XX_EXP_CS0;
-+
-+ platform_add_devices(gateway7001_devices, ARRAY_SIZE(gateway7001_devices));
-+}
-+
-+#ifdef CONFIG_MACH_GATEWAY7001
-+MACHINE_START(GATEWAY7001, "Gateway 7001 AP")
-+ /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
-+ .phys_io = IXP4XX_PERIPHERAL_BASE_PHYS,
-+ .io_pg_offst = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
-+ .map_io = ixp4xx_map_io,
-+ .init_irq = ixp4xx_init_irq,
-+ .timer = &ixp4xx_timer,
-+ .boot_params = 0x0100,
-+ .init_machine = gateway7001_init,
-+MACHINE_END
-+#endif
-Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/arch/arm/mach-ixp4xx/Kconfig
-+++ linux-2.6.21.7/arch/arm/mach-ixp4xx/Kconfig
-@@ -41,6 +41,14 @@ config ARCH_ADI_COYOTE
- Engineering Coyote Gateway Reference Platform. For more
- information on this platform, see <file:Documentation/arm/IXP4xx>.
-
-+config MACH_GATEWAY7001
-+ bool "Gateway 7001"
-+ select PCI
-+ help
-+ Say 'Y' here if you want your kernel to support Gateway's
-+ 7001 Access Point. For more information on this platform,
-+ see http://openwrt.org
-+
- config ARCH_IXDP425
- bool "IXDP425"
- help
-Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/Makefile
-===================================================================
---- linux-2.6.21.7.orig/arch/arm/mach-ixp4xx/Makefile
-+++ linux-2.6.21.7/arch/arm/mach-ixp4xx/Makefile
-@@ -13,6 +13,7 @@ obj-pci-$(CONFIG_MACH_GTWX5715) += gtwx
- obj-pci-$(CONFIG_MACH_NSLU2) += nslu2-pci.o
- obj-pci-$(CONFIG_MACH_NAS100D) += nas100d-pci.o
- obj-pci-$(CONFIG_MACH_DSMG600) += dsmg600-pci.o
-+obj-pci-$(CONFIG_MACH_GATEWAY7001) += gateway7001-pci.o
-
- obj-y += common.o
-
-@@ -24,5 +25,6 @@ obj-$(CONFIG_MACH_GTWX5715) += gtwx5715-
- obj-$(CONFIG_MACH_NSLU2) += nslu2-setup.o nslu2-power.o
- obj-$(CONFIG_MACH_NAS100D) += nas100d-setup.o nas100d-power.o
- obj-$(CONFIG_MACH_DSMG600) += dsmg600-setup.o dsmg600-power.o
-+obj-$(CONFIG_MACH_GATEWAY7001) += gateway7001-setup.o
-
- obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
-Index: linux-2.6.21.7/include/asm-arm/arch-ixp4xx/uncompress.h
-===================================================================
---- linux-2.6.21.7.orig/include/asm-arm/arch-ixp4xx/uncompress.h
-+++ linux-2.6.21.7/include/asm-arm/arch-ixp4xx/uncompress.h
-@@ -38,9 +38,9 @@ static void flush(void)
- static __inline__ void __arch_decomp_setup(unsigned long arch_id)
- {
- /*
-- * Coyote and gtwx5715 only have UART2 connected
-+ * Some boards are using UART2 as console
- */
-- if (machine_is_adi_coyote() || machine_is_gtwx5715())
-+ if (machine_is_adi_coyote() || machine_is_gtwx5715() || machine_is_gateway7001())
- uart_base = (volatile u32*) IXP4XX_UART2_BASE_PHYS;
- else
- uart_base = (volatile u32*) IXP4XX_UART1_BASE_PHYS;