aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.25/400-ledtrig_morse.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.25/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-2.6.25/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.25/400-ledtrig_morse.patch b/target/linux/generic/patches-2.6.25/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..7208dde0ef
--- /dev/null
+++ b/target/linux/generic/patches-2.6.25/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -181,4 +181,8 @@ config LEDS_TRIGGER_HEARTBEAT
+ load average.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -26,3 +26,4 @@ obj-$(CONFIG_LEDS_HP6XX) += leds-hp6xx.
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o