aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/coldfire/patches-2.6.31/006-mcf548x_ethernet.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/coldfire/patches-2.6.31/006-mcf548x_ethernet.patch')
-rw-r--r--target/linux/coldfire/patches-2.6.31/006-mcf548x_ethernet.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/target/linux/coldfire/patches-2.6.31/006-mcf548x_ethernet.patch b/target/linux/coldfire/patches-2.6.31/006-mcf548x_ethernet.patch
deleted file mode 100644
index 22fb901b28..0000000000
--- a/target/linux/coldfire/patches-2.6.31/006-mcf548x_ethernet.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/drivers/net/Kconfig
-+++ b/drivers/net/Kconfig
-@@ -2010,6 +2010,29 @@ config FEC2
- Say Y here if you want to use the second built-in 10/100 Fast
- ethernet controller on some Motorola ColdFire processors.
-
-+config FEC_548x
-+ tristate "MCF547x/MCF548x Fast Ethernet Controller support"
-+ depends on M547X_8X
-+ select PHYLIB
-+ help
-+ The MCF547x and MCF548x have a built-in Fast Ethernet Controller.
-+ Saying Y here will include support for this device in the kernel.
-+
-+ To compile this driver as a module, choose M here: the module
-+ will be called fecm.
-+
-+config FEC_548x_ENABLE_FEC2
-+ bool "Enable the second FEC"
-+ depends on FEC_548x
-+ help
-+ This enables the second FEC on the 547x/548x.
-+
-+config FEC_548x_SHARED_PHY
-+ bool "Shared PHY interface(on some ColdFire designs)"
-+ depends on FEC_548x_ENABLE_FEC2
-+ help
-+ Say Y here if both PHYs are controlled via a single channel.+
-+
- config FEC_MPC52xx
- tristate "MPC52xx FEC driver"
- depends on PPC_MPC52xx && PPC_BESTCOMM
---- a/drivers/net/Makefile
-+++ b/drivers/net/Makefile
-@@ -114,6 +114,7 @@ obj-$(CONFIG_PCMCIA_PCNET) += 8390.o
- obj-$(CONFIG_HP100) += hp100.o
- obj-$(CONFIG_SMC9194) += smc9194.o
- obj-$(CONFIG_FEC) += fec.o
-+obj-$(CONFIG_FEC_548x) += fec_m547x.o
- obj-$(CONFIG_FEC_MPC52xx) += fec_mpc52xx.o
- ifeq ($(CONFIG_FEC_MPC52xx_MDIO),y)
- obj-$(CONFIG_FEC_MPC52xx) += fec_mpc52xx_phy.o