aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch')
-rw-r--r--target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch32
1 files changed, 22 insertions, 10 deletions
diff --git a/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch
index 91916e6387..9927f6d73a 100644
--- a/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch
@@ -1,12 +1,13 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,17 +16,78 @@
+@@ -16,17 +16,79 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
+ ATH79_MACH_ALFA_AP96, /* ALFA Network AP96 board */
+ ATH79_MACH_ALFA_NX, /* ALFA Network N2/N5 board */
+ ATH79_MACH_ALL0258N, /* Allnet ALL0258N */
++ ATH79_MACH_AP113, /* Atheros AP113 reference board */
ATH79_MACH_AP121, /* Atheros AP121 reference board */
ATH79_MACH_AP121_MINI, /* Atheros AP121-MINI reference board */
ATH79_MACH_AP81, /* Atheros AP81 reference board */
@@ -81,7 +82,7 @@
#endif /* _ATH79_MACHTYPE_H */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -2,6 +2,42 @@ if ATH79
+@@ -2,6 +2,52 @@ if ATH79
menu "Atheros AR71XX/AR724X/AR913X machine selection"
@@ -121,10 +122,20 @@
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
++config ATH79_MACH_AP113
++ bool "Atheros AP113 board support"
++ select SOC_AR724X
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_PB9X_PCI if PCI
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_USB
++ select ATH79_DEV_ETH
++
config ATH79_MACH_AP121
bool "Atheros AP121 reference board"
select SOC_AR933X
-@@ -28,6 +64,36 @@ config ATH79_MACH_AP81
+@@ -28,6 +74,36 @@ config ATH79_MACH_AP81
Say 'Y' here if you want your kernel to support the
Atheros AP81 reference board.
@@ -161,7 +172,7 @@
config ATH79_MACH_DB120
bool "Atheros DB120 reference board"
select SOC_AR934X
-@@ -42,6 +108,13 @@ config ATH79_MACH_DB120
+@@ -42,6 +118,13 @@ config ATH79_MACH_DB120
Say 'Y' here if you want your kernel to support the
Atheros DB120 reference board.
@@ -175,7 +186,7 @@
config ATH79_MACH_PB44
bool "Atheros PB44 reference board"
select SOC_AR71XX
-@@ -54,6 +127,359 @@ config ATH79_MACH_PB44
+@@ -54,6 +137,359 @@ config ATH79_MACH_PB44
Say 'Y' here if you want your kernel to support the
Atheros PB44 reference board.
@@ -535,7 +546,7 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM (rev 1.0) board"
select SOC_AR724X
-@@ -67,6 +483,24 @@ config ATH79_MACH_UBNT_XM
+@@ -67,6 +503,24 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@@ -560,7 +571,7 @@
endmenu
config SOC_AR71XX
-@@ -96,10 +530,6 @@ config SOC_AR934X
+@@ -96,10 +550,6 @@ config SOC_AR934X
select PCI_AR724X if PCI
def_bool n
@@ -571,7 +582,7 @@
config ATH79_DEV_AP9X_PCI
select ATH79_PCI_ATH9K_FIXUP
def_bool n
-@@ -110,7 +540,14 @@ config ATH79_DEV_DSA
+@@ -110,7 +560,14 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -587,7 +598,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -135,4 +572,7 @@ config ATH79_NVRAM
+@@ -135,4 +592,7 @@ config ATH79_NVRAM
config ATH79_PCI_ATH9K_FIXUP
def_bool n
@@ -597,13 +608,14 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -36,8 +36,54 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += p
+@@ -36,8 +36,55 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += p
#
# Machines
#
+obj-$(CONFIG_ATH79_MACH_ALFA_AP96) += mach-alfa-ap96.o
+obj-$(CONFIG_ATH79_MACH_ALFA_NX) += mach-alfa-nx.o
+obj-$(CONFIG_ATH79_MACH_ALL0258N) += mach-all0258n.o
++obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o
obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
obj-$(CONFIG_ATH79_MACH_AP81) += mach-ap81.o
+obj-$(CONFIG_ATH79_MACH_AP83) += mach-ap83.o