aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.25/100-board_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar7/patches-2.6.25/100-board_support.patch')
-rw-r--r--target/linux/ar7/patches-2.6.25/100-board_support.patch32
1 files changed, 16 insertions, 16 deletions
diff --git a/target/linux/ar7/patches-2.6.25/100-board_support.patch b/target/linux/ar7/patches-2.6.25/100-board_support.patch
index 08cf79be2e..9b86db6a34 100644
--- a/target/linux/ar7/patches-2.6.25/100-board_support.patch
+++ b/target/linux/ar7/patches-2.6.25/100-board_support.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.25.1/arch/mips/Kconfig
+Index: linux-2.6.25.4/arch/mips/Kconfig
===================================================================
---- linux-2.6.25.1.orig/arch/mips/Kconfig 2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/arch/mips/Kconfig 2008-05-03 16:17:54.000000000 +0200
-@@ -18,6 +18,24 @@
+--- linux-2.6.25.4.orig/arch/mips/Kconfig
++++ linux-2.6.25.4/arch/mips/Kconfig
+@@ -18,6 +18,24 @@ choice
prompt "System type"
default SGI_IP22
@@ -27,11 +27,11 @@ Index: linux-2.6.25.1/arch/mips/Kconfig
config MACH_ALCHEMY
bool "Alchemy processor based machines"
-Index: linux-2.6.25.1/arch/mips/kernel/traps.c
+Index: linux-2.6.25.4/arch/mips/kernel/traps.c
===================================================================
---- linux-2.6.25.1.orig/arch/mips/kernel/traps.c 2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/arch/mips/kernel/traps.c 2008-05-03 16:17:54.000000000 +0200
-@@ -1112,9 +1112,22 @@
+--- linux-2.6.25.4.orig/arch/mips/kernel/traps.c
++++ linux-2.6.25.4/arch/mips/kernel/traps.c
+@@ -1112,9 +1112,22 @@ void *set_except_vector(int n, void *add
exception_handlers[n] = handler;
if (n == 0 && cpu_has_divec) {
@@ -57,11 +57,11 @@ Index: linux-2.6.25.1/arch/mips/kernel/traps.c
}
return (void *)old_handler;
}
-Index: linux-2.6.25.1/arch/mips/Makefile
+Index: linux-2.6.25.4/arch/mips/Makefile
===================================================================
---- linux-2.6.25.1.orig/arch/mips/Makefile 2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/arch/mips/Makefile 2008-05-03 16:17:54.000000000 +0200
-@@ -167,6 +167,13 @@
+--- linux-2.6.25.4.orig/arch/mips/Makefile
++++ linux-2.6.25.4/arch/mips/Makefile
+@@ -167,6 +167,13 @@ libs-$(CONFIG_SIBYTE_CFE) += arch/mips/s
#
#
@@ -75,11 +75,11 @@ Index: linux-2.6.25.1/arch/mips/Makefile
# Acer PICA 61, Mips Magnum 4000 and Olivetti M700.
#
core-$(CONFIG_MACH_JAZZ) += arch/mips/jazz/
-Index: linux-2.6.25.1/include/asm-mips/page.h
+Index: linux-2.6.25.4/include/asm-mips/page.h
===================================================================
---- linux-2.6.25.1.orig/include/asm-mips/page.h 2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/include/asm-mips/page.h 2008-05-03 16:17:54.000000000 +0200
-@@ -182,8 +182,10 @@
+--- linux-2.6.25.4.orig/include/asm-mips/page.h
++++ linux-2.6.25.4/include/asm-mips/page.h
+@@ -182,8 +182,10 @@ typedef struct { unsigned long pgprot; }
#define VM_DATA_DEFAULT_FLAGS (VM_READ | VM_WRITE | VM_EXEC | \
VM_MAYREAD | VM_MAYWRITE | VM_MAYEXEC)