aboutsummaryrefslogtreecommitdiffstats
path: root/package/pptp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/pptp/Makefile')
-rw-r--r--package/pptp/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/package/pptp/Makefile b/package/pptp/Makefile
index 3772adb064..e44806bdd2 100644
--- a/package/pptp/Makefile
+++ b/package/pptp/Makefile
@@ -36,13 +36,24 @@ endef
MAKE_FLAGS += OPTIMIZE="$(TARGET_CFLAGS)"
-define Package/pptp/install
+ifneq ($(CONFIG_PACKAGE_netifd),)
+ define Package/pptp/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/ppp
$(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
$(INSTALL_DIR) $(1)/lib/network
$(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
-endef
+ endef
+else
+ define Package/pptp/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/ppp
+ $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_DATA) ./files.old/pptp.sh $(1)/lib/network/
+ endef
+endif
$(eval $(call BuildPackage,pptp))