aboutsummaryrefslogtreecommitdiffstats
path: root/package/pmacct
diff options
context:
space:
mode:
Diffstat (limited to 'package/pmacct')
-rw-r--r--package/pmacct/Config.in215
-rw-r--r--package/pmacct/Makefile184
-rw-r--r--package/pmacct/files/nfacctd.conf28
-rw-r--r--package/pmacct/files/nfacctd.default1
-rw-r--r--package/pmacct/files/nfacctd.init22
-rw-r--r--package/pmacct/files/pmacctd.conf26
-rw-r--r--package/pmacct/files/pmacctd.default1
-rw-r--r--package/pmacct/files/pmacctd.init22
-rw-r--r--package/pmacct/ipkg/nfacctd-custom.control6
-rw-r--r--package/pmacct/ipkg/nfacctd-mysql.control6
-rw-r--r--package/pmacct/ipkg/nfacctd-pgsql.control6
-rw-r--r--package/pmacct/ipkg/nfacctd-sqlite.control6
-rw-r--r--package/pmacct/ipkg/nfacctd.conffiles2
-rw-r--r--package/pmacct/ipkg/nfacctd.control6
-rw-r--r--package/pmacct/ipkg/pmacct-client.control5
-rw-r--r--package/pmacct/ipkg/pmacctd-custom.control6
-rw-r--r--package/pmacct/ipkg/pmacctd-mysql.control6
-rw-r--r--package/pmacct/ipkg/pmacctd-pgsql.control6
-rw-r--r--package/pmacct/ipkg/pmacctd-sqlite.control6
-rw-r--r--package/pmacct/ipkg/pmacctd.conffiles2
-rw-r--r--package/pmacct/ipkg/pmacctd.control6
21 files changed, 0 insertions, 568 deletions
diff --git a/package/pmacct/Config.in b/package/pmacct/Config.in
deleted file mode 100644
index 2c6289113c..0000000000
--- a/package/pmacct/Config.in
+++ /dev/null
@@ -1,215 +0,0 @@
-menu "pmacct............................ IPv4/IPv6 accounting and aggregation tools"
-
-config BR2_COMPILE_PMACCT
- tristate
- default n
- depends BR2_COMPILE_PMACCT_BASIC || BR2_COMPILE_PMACCT_MYSQL || BR2_COMPILE_PMACCT_PGSQL || BR2_COMPILE_PMACCT_SQLITE || BR2_COMPILE_PMACCT_CUSTOM
-
-config BR2_COMPILE_PMACCT_BASIC
- tristate
- default n
- depends BR2_PACKAGE_NFACCTD_BASIC || BR2_PACKAGE_PMACCTD_BASIC
- select BR2_COMPILE_PMACCT
-
-config BR2_COMPILE_PMACCT_MYSQL
- tristate
- default n
- depends BR2_PACKAGE_NFACCTD_MYSQL || BR2_PACKAGE_PMACCTD_MYSQL
- select BR2_COMPILE_PMACCT
-
-config BR2_COMPILE_PMACCT_PGSQL
- tristate
- default n
- depends BR2_PACKAGE_NFACCTD_PGSQL || BR2_PACKAGE_PMACCTD_PGSQL
- select BR2_COMPILE_PMACCT
-
-config BR2_COMPILE_PMACCT_SQLITE
- tristate
- default n
- depends BR2_PACKAGE_NFACCTD_SQLITE || BR2_PACKAGE_PMACCTD_SQLITE
- select BR2_COMPILE_PMACCT
-
-config BR2_COMPILE_PMACCT_CUSTOM
- tristate
- default n
- depends BR2_PACKAGE_NFACCTD_CUSTOM || BR2_PACKAGE_PMACCTD_CUSTOM
- select BR2_COMPILE_PMACCT
-
-choice
- prompt "nfacctd......................... NetFlow accounting daemon"
- tristate
- default m if CONFIG_DEVEL
- optional
- help
-
- An IPv4/IPv6 Netflow accounting and aggregation daemon
-
- http://www.ba.cnr.it/~paolo/pmacct/
-
- Depends:
- - libmysqlclient (for MySQL database logging support)
- - libpq (for PostgreSQL database logging support)
- - libsqlite (for SQLite database logging support)
-
-
- config BR2_PACKAGE_NFACCTD_BASIC
- prompt "nfacctd....................... built without database support"
- tristate
- select BR2_COMPILE_PMACCT_BASIC
- select BR2_PACKAGE_LIBPCAP
-
- config BR2_PACKAGE_NFACCTD_MYSQL
- prompt "nfacctd-mysql................. built with MySQL database support"
- tristate
- select BR2_COMPILE_PMACCT_MYSQL
- select BR2_PACKAGE_LIBPCAP
- select BR2_PACKAGE_LIBMYSQLCLIENT
-
- config BR2_PACKAGE_NFACCTD_PGSQL
- prompt "nfacctd-pgsql................. built with PostgreSQL database support"
- tristate
- select BR2_COMPILE_PMACCT_PGSQL
- select BR2_PACKAGE_LIBPCAP
- select BR2_PACKAGE_LIBPQ
-
- config BR2_PACKAGE_NFACCTD_SQLITE
- prompt "nfacctd-sqlite................ built with SQLite database support"
- tristate
- select BR2_COMPILE_PMACCT_SQLITE
- select BR2_PACKAGE_LIBPCAP
- select BR2_PACKAGE_LIBSQLITE
-
- config BR2_PACKAGE_NFACCTD_CUSTOM
- prompt "nfacctd-custom................ customized to your needs"
- tristate
- select BR2_COMPILE_PMACCT_CUSTOM
- select BR2_PACKAGE_LIBPCAP
-
- config BR2_COMPILE_NFACCTD_ENABLE_DEBUG
- prompt "debug (enable debugging options, useful for bugreports)"
- bool
- default n
- depends BR2_PACKAGE_NFACCTD_CUSTOM
-
- config BR2_COMPILE_NFACCTD_ENABLE_IPV6
- prompt "IPv6 support"
- bool
- default n
- depends BR2_PACKAGE_NFACCTD_CUSTOM
-
- config BR2_COMPILE_NFACCTD_WITH_MYSQL
- prompt "MySQL database support"
- bool
- default n
- depends BR2_PACKAGE_NFACCTD_CUSTOM
- select BR2_PACKAGE_LIBMYSQLCLIENT
-
- config BR2_COMPILE_NFACCTD_WITH_PGSQL
- prompt "PostgreSQL database support"
- bool
- default n
- depends BR2_PACKAGE_NFACCTD_CUSTOM
- select BR2_PACKAGE_LIBPQ
-
- config BR2_COMPILE_NFACCTD_WITH_SQLITE
- prompt "SQLite database support"
- bool
- default n
- depends BR2_PACKAGE_NFACCTD_CUSTOM
- select BR2_PACKAGE_LIBSQLITE
-
-endchoice
-
-choice
- prompt "pmacctd......................... IP accounting daemon (libpcap based)"
- tristate
- default m if CONFIG_DEVEL
- optional
- help
-
- An IPv4/IPv6 libpcap-based accounting and aggregation daemon
-
- http://www.ba.cnr.it/~paolo/pmacct/
-
- Depends:
- - libpcap
- - libmysqlclient (for MySQL database logging support)
- - libpq (for PostgreSQL database logging support)
- - libsqlite (for SQLite database logging support)
-
-
- config BR2_PACKAGE_PMACCTD_BASIC
- prompt "pmacctd....................... built without database support"
- tristate
- select BR2_COMPILE_PMACCT_BASIC
- select BR2_PACKAGE_LIBPCAP
-
- config BR2_PACKAGE_PMACCTD_MYSQL
- prompt "pmacctd-mysql................. built with MySQL database support"
- tristate
- select BR2_COMPILE_PMACCT_MYSQL
- select BR2_PACKAGE_LIBPCAP
- select BR2_PACKAGE_LIBMYSQLCLIENT
-
- config BR2_PACKAGE_PMACCTD_PGSQL
- prompt "pmacctd-pgsql................. built with PostgreSQL database support"
- tristate
- select BR2_COMPILE_PMACCT_PGSQL
- select BR2_PACKAGE_LIBPCAP
- select BR2_PACKAGE_LIBPQ
-
- config BR2_PACKAGE_PMACCTD_SQLITE
- prompt "pmacctd-sqlite................ built with SQLite database support"
- tristate
- select BR2_COMPILE_PMACCT_SQLITE
- select BR2_PACKAGE_LIBPCAP
- select BR2_PACKAGE_LIBSQLITE
-
- config BR2_PACKAGE_PMACCTD_CUSTOM
- prompt "pmacctd-custom................ customized to your needs"
- tristate
- select BR2_COMPILE_PMACCT_CUSTOM
- select BR2_PACKAGE_LIBPCAP
-
- config BR2_COMPILE_PMACCTD_ENABLE_DEBUG
- prompt "debug (enable debugging options, useful for bugreports)"
- bool
- default n
- depends BR2_PACKAGE_PMACCTD_CUSTOM
-
- config BR2_COMPILE_PMACCTD_ENABLE_IPV6
- prompt "IPv6 support"
- bool
- default n
- depends BR2_PACKAGE_PMACCTD_CUSTOM
-
- config BR2_COMPILE_PMACCTD_WITH_MYSQL
- prompt "MySQL database support"
- bool
- default n
- depends BR2_PACKAGE_PMACCTD_CUSTOM
- select BR2_PACKAGE_LIBMYSQLCLIENT
-
- config BR2_COMPILE_PMACCTD_WITH_PGSQL
- prompt "PostgreSQL database support"
- bool
- default n
- depends BR2_PACKAGE_PMACCTD_CUSTOM
- select BR2_PACKAGE_LIBPQ
-
- config BR2_COMPILE_PMACCTD_WITH_SQLITE
- prompt "SQLite database support"
- bool
- default n
- depends BR2_PACKAGE_PMACCTD_CUSTOM
- select BR2_PACKAGE_LIBSQLITE
-
-endchoice
-
-config BR2_PACKAGE_PMACCT_CLIENT
- prompt "pmacct-client................... Command-line client to gather data from the IMT plugin"
- tristate
- default n
- select BR2_COMPILE_PMACCT
-
-endmenu
diff --git a/package/pmacct/Makefile b/package/pmacct/Makefile
deleted file mode 100644
index a9bd44b52b..0000000000
--- a/package/pmacct/Makefile
+++ /dev/null
@@ -1,184 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=pmacct
-PKG_VERSION:=0.10.0
-PKG_RELEASE:=1
-PKG_MD5SUM:=ed510e7ee2130d1f37f27901b89e985a
-
-PKG_SOURCE_URL:=http://www.ba.cnr.it/~paolo/pmacct/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)rc2.tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-PMACCT_BASIC_CONFIGURE_OPTS := \
-
-PMACCT_MYSQL_CONFIGURE_OPTS := \
- --enable-mysql \
- --with-mysql-includes="$(STAGING_DIR)/usr/include" \
- --with-mysql-libs="$(STAGING_DIR)/usr/lib/mysql"
-
-PMACCT_PGSQL_CONFIGURE_OPTS := \
- --enable-pgsql \
- --with-pgsql-includes="$(STAGING_DIR)/usr/include" \
- --with-pgsql-libs="$(STAGING_DIR)/usr/lib"
-
-PMACCT_SQLITE_CONFIGURE_OPTS := \
- --enable-sqlite3 \
- --with-sqlite3-includes="$(STAGING_DIR)/usr/include" \
- --with-sqlite3-libs="$(STAGING_DIR)/usr/lib"
-
-NFACCTD_CUSTOM_CONFIGURE_OPTS := \
-
-ifeq ($(BR2_PACKAGE_NFACCTD_ENABLE_DEBUG),y)
-NFACCTD_CUSTOM_CONFIGURE_OPTS += --enable-debug
-endif
-
-ifeq ($(BR2_PACKAGE_NFACCTD_ENABLE_IPV6),y)
-NFACCTD_CUSTOM_CONFIGURE_OPTS += --enable-ipv6
-endif
-
-ifeq ($(BR2_PACKAGE_NFACCTD_WITH_MYSQL),y)
-NFACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_MYSQL_CONFIGURE_OPTS)
-endif
-
-ifeq ($(BR2_PACKAGE_NFACCTD_WITH_PGSQL),y)
-NFACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_PGSQL_CONFIGURE_OPTS)
-endif
-
-ifeq ($(BR2_PACKAGE_NFACCTD_WITH_SQLITE),y)
-NFACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_SQLITE_CONFIGURE_OPTS)
-endif
-
-PMACCTD_CUSTOM_CONFIGURE_OPTS := \
-
-ifeq ($(BR2_PACKAGE_PMACCTD_ENABLE_DEBUG),y)
-PMACCTD_CUSTOM_CONFIGURE_OPTS += --enable-debug
-endif
-
-ifeq ($(BR2_PACKAGE_PMACCTD_ENABLE_IPV6),y)
-PMACCTD_CUSTOM_CONFIGURE_OPTS += --enable-ipv6
-endif
-
-ifeq ($(BR2_PACKAGE_PMACCTD_WITH_MYSQL),y)
-PMACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_MYSQL_CONFIGURE_OPTS)
-endif
-
-ifeq ($(BR2_PACKAGE_PMACCTD_WITH_PGSQL),y)
-PMACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_PGSQL_CONFIGURE_OPTS)
-endif
-
-ifeq ($(BR2_PACKAGE_PMACCTD_WITH_SQLITE),y)
-PMACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_SQLITE_CONFIGURE_OPTS)
-endif
-
-define PKG_build
-
-ifneq ($(BR2_PACKAGE_$(1)),)
-BUILD_TARGETS += $(PKG_BUILD_DIR)/$(2)
-BUILD_TARGETS += $(PKG_BUILD_DIR)/$(3)
-endif
-
-$(PKG_BUILD_DIR)/$(2) $(PKG_BUILD_DIR)/$(3): $(PKG_BUILD_DIR)/.prepared
- -$(MAKE) -C $(PKG_BUILD_DIR) distclean
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/sbin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib/locate \
- --localstatedir=/var/lib \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --disable-static \
- --with-pcap-includes="$(STAGING_DIR)/usr/include" \
- --with-pcap-libs="$(STAGING_DIR)/usr/lib" \
- $$($(1)_CONFIGURE_OPTS) \
- );
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include"
- mv -f $(PKG_BUILD_DIR)/nfacctd $(PKG_BUILD_DIR)/$(2)
- mv -f $(PKG_BUILD_DIR)/pmacctd $(PKG_BUILD_DIR)/$(3)
-
-endef
-
-define PKG_package
-
-$$(IPKG_$(1)): $(PKG_BUILD_DIR)/$(2)
- install -d -m0755 $$(IDIR_$(1))/etc
- install -m0644 ./files/$(3).conf $$(IDIR_$(1))/etc/
- install -d -m0755 $$(IDIR_$(1))/etc/default
- install -m0644 ./files/$(3).default $$(IDIR_$(1))/etc/default/$(3)
- install -d -m0755 $$(IDIR_$(1))/etc/init.d
- install -m0755 ./files/$(3).init $$(IDIR_$(1))/etc/init.d/$(3)
- install -d -m0755 $$(IDIR_$(1))/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/$(2) $$(IDIR_$(1))/usr/sbin/$(3)
- $(RSTRIP) $$(IDIR_$(1))
- $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
-
-endef
-
-$(eval $(call PKG_template,NFACCTD_BASIC,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,NFACCTD_MYSQL,nfacctd-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,NFACCTD_PGSQL,nfacctd-pgsql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,NFACCTD_SQLITE,nfacctd-sqlite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,NFACCTD_CUSTOM,nfacctd-custom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,PMACCTD_BASIC,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,PMACCTD_MYSQL,pmacctd-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,PMACCTD_PGSQL,pmacctd-pgsql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,PMACCTD_SQLITE,pmacctd-sqlite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,PMACCTD_CUSTOM,pmacctd-custom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,PMACCT_CLIENT,pmacct-client,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(eval $(call PKG_build,PMACCT_BASIC,nfacctd-basic,pmacctd-basic,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_build,PMACCT_MYSQL,nfacctd-mysql,pmacctd-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_build,PMACCT_PGSQL,nfacctd-pgsql,pmacctd-pgsql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_build,PMACCT_SQLITE,nfacctd-sqlite,pmacctd-sqlite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_build,NFACCTD_CUSTOM,nfacctd-custom,pmacctd-dummy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_build,PMACCTD_CUSTOM,nfacctd-dummy,pmacctd-custom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(eval $(call PKG_package,NFACCTD_BASIC,nfacctd-basic,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_package,NFACCTD_MYSQL,nfacctd-mysql,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_package,NFACCTD_PGSQL,nfacctd-pgsql,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_package,NFACCTD_SQLITE,nfacctd-sqlite,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_package,NFACCTD_CUSTOM,nfacctd-custom,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_package,PMACCTD_BASIC,pmacctd-basic,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_package,PMACCTD_MYSQL,pmacctd-mysql,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_package,PMACCTD_PGSQL,pmacctd-pgsql,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_package,PMACCTD_SQLITE,pmacctd-sqlite,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_package,PMACCTD_CUSTOM,pmacctd-custom,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built: $(BUILD_TARGETS)
- touch $@
-
-$(IPKG_PMACCT_CLIENT):
- install -d -m0755 $(IDIR_PMACCT_CLIENT)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/pmacct $(IDIR_PMACCT_CLIENT)/usr/sbin/
- $(RSTRIP) $(IDIR_PMACCT_CLIENT)
- $(IPKG_BUILD) $(IDIR_PMACCT_CLIENT) $(PACKAGE_DIR)
diff --git a/package/pmacct/files/nfacctd.conf b/package/pmacct/files/nfacctd.conf
deleted file mode 100644
index a9817b2185..0000000000
--- a/package/pmacct/files/nfacctd.conf
+++ /dev/null
@@ -1,28 +0,0 @@
-!
-! nfacctd configuration example
-!
-! debug: true
-daemonize: true
-pidfile: /var/run/nfacctd.pid
-! aggregate_filter[dummy]: src net 192.168.0.0/16
-aggregate: src_host, dst_host
-! plugin_buffer_size: 1024
-! nfacctd_port: 5678
-! nfacctd_time_secs: true
-! nfacctd_time_new: true
-plugins: memory
-imt_buckets: 65537
-imt_mem_pools_size: 65536
-! imt_mem_pools_number: 0
-! plugins: mysql
-! plugins: pgsql
-! sql_db: pmacct
-! sql_table: acct
-! sql_table_version: 2
-! sql_passwd: arealsmartpwd
-! sql_user: pmacct
-! sql_refresh_time: 90
-! sql_optimize_clauses: true
-! sql_history: 10m
-! sql_history_roundoff: mh
-! networks_file: ./networks.example
diff --git a/package/pmacct/files/nfacctd.default b/package/pmacct/files/nfacctd.default
deleted file mode 100644
index 9315b280c9..0000000000
--- a/package/pmacct/files/nfacctd.default
+++ /dev/null
@@ -1 +0,0 @@
-OPTIONS="-f /etc/nfacctd.conf"
diff --git a/package/pmacct/files/nfacctd.init b/package/pmacct/files/nfacctd.init
deleted file mode 100644
index c38c7f14b2..0000000000
--- a/package/pmacct/files/nfacctd.init
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh
-
-BIN=nfacctd
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- mkdir -p $RUN_D
- $BIN $OPTIONS
- ;;
- stop)
- [ -f $PID_F ] && kill -INT $(cat $PID_F)
- ;;
- *)
- echo "usage: $0 (start|stop)"
- exit 1
-esac
-
-exit $?
diff --git a/package/pmacct/files/pmacctd.conf b/package/pmacct/files/pmacctd.conf
deleted file mode 100644
index 65c6387ea3..0000000000
--- a/package/pmacct/files/pmacctd.conf
+++ /dev/null
@@ -1,26 +0,0 @@
-!
-! pmacctd configuration example
-!
-! debug: true
-interface: vlan1
-daemonize: true
-pidfile: /var/run/pmacctd.pid
-pmacctd_id: 1
-aggregate: src_host,dst_host
-! aggregate: src_net,dst_net
-plugins: memory
-imt_buckets: 65537
-imt_mem_pools_size: 65536
-! imt_mem_pools_number: 0
-! plugins: mysql
-! plugins: pgsql
-! sql_db: pmacct
-! sql_table: acct
-! sql_table_version: 2
-! sql_passwd: arealsmartpwd
-! sql_user: pmacct
-! sql_refresh_time: 90
-! sql_optimize_clauses: true
-! sql_history: 10m
-! sql_history_roundoff: mh
-! networks_file: ./networks.example
diff --git a/package/pmacct/files/pmacctd.default b/package/pmacct/files/pmacctd.default
deleted file mode 100644
index 3c06f085f6..0000000000
--- a/package/pmacct/files/pmacctd.default
+++ /dev/null
@@ -1 +0,0 @@
-OPTIONS="-f /etc/pmacctd.conf"
diff --git a/package/pmacct/files/pmacctd.init b/package/pmacct/files/pmacctd.init
deleted file mode 100644
index 0af1095000..0000000000
--- a/package/pmacct/files/pmacctd.init
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh
-
-BIN=pmacctd
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- mkdir -p $RUN_D
- $BIN $OPTIONS
- ;;
- stop)
- [ -f $PID_F ] && kill -INT $(cat $PID_F)
- ;;
- *)
- echo "usage: $0 (start|stop)"
- exit 1
-esac
-
-exit $?
diff --git a/package/pmacct/ipkg/nfacctd-custom.control b/package/pmacct/ipkg/nfacctd-custom.control
deleted file mode 100644
index 096be7e04a..0000000000
--- a/package/pmacct/ipkg/nfacctd-custom.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: nfacctd-custom
-Priority: optional
-Section: net
-Description: a NetFlow accounting daemon,
- built with custom options
-Depends: libpcap
diff --git a/package/pmacct/ipkg/nfacctd-mysql.control b/package/pmacct/ipkg/nfacctd-mysql.control
deleted file mode 100644
index e030db8fcc..0000000000
--- a/package/pmacct/ipkg/nfacctd-mysql.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: nfacctd-mysql
-Priority: optional
-Section: net
-Description: a NetFlow accounting daemon,
- built with MySQL database support
-Depends: libmysqlclient, libpcap
diff --git a/package/pmacct/ipkg/nfacctd-pgsql.control b/package/pmacct/ipkg/nfacctd-pgsql.control
deleted file mode 100644
index 8500ff3426..0000000000
--- a/package/pmacct/ipkg/nfacctd-pgsql.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: nfacctd-pgsql
-Priority: optional
-Section: net
-Description: a NetFlow accounting daemon,
- built with PostgreSQL database support
-Depends: libpq, libpcap
diff --git a/package/pmacct/ipkg/nfacctd-sqlite.control b/package/pmacct/ipkg/nfacctd-sqlite.control
deleted file mode 100644
index add839416b..0000000000
--- a/package/pmacct/ipkg/nfacctd-sqlite.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: nfacctd-sqlite
-Priority: optional
-Section: net
-Description: a NetFlow accounting daemon,
- built with SQLite database support
-Depends: libsqlite, libpcap
diff --git a/package/pmacct/ipkg/nfacctd.conffiles b/package/pmacct/ipkg/nfacctd.conffiles
deleted file mode 100644
index dec6203510..0000000000
--- a/package/pmacct/ipkg/nfacctd.conffiles
+++ /dev/null
@@ -1,2 +0,0 @@
-/etc/default/nfacctd
-/etc/nfacctd.conf
diff --git a/package/pmacct/ipkg/nfacctd.control b/package/pmacct/ipkg/nfacctd.control
deleted file mode 100644
index e5afbf68d3..0000000000
--- a/package/pmacct/ipkg/nfacctd.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: nfacctd
-Priority: optional
-Section: net
-Description: a NetFlow accounting daemon,
- built without database support
-Depends: libpcap
diff --git a/package/pmacct/ipkg/pmacct-client.control b/package/pmacct/ipkg/pmacct-client.control
deleted file mode 100644
index c943e731e5..0000000000
--- a/package/pmacct/ipkg/pmacct-client.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: pmacct-client
-Priority: optional
-Section: net
-Description: a command-line client for pmacctd or nfacctd,
- used to retrieve data from an active memory plugin
diff --git a/package/pmacct/ipkg/pmacctd-custom.control b/package/pmacct/ipkg/pmacctd-custom.control
deleted file mode 100644
index 0278df1426..0000000000
--- a/package/pmacct/ipkg/pmacctd-custom.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: pmacctd-custom
-Priority: optional
-Section: net
-Description: an IP accounting daemon,
- built with custom options
-Depends: libpcap
diff --git a/package/pmacct/ipkg/pmacctd-mysql.control b/package/pmacct/ipkg/pmacctd-mysql.control
deleted file mode 100644
index 2ea345fcb6..0000000000
--- a/package/pmacct/ipkg/pmacctd-mysql.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: pmacctd-mysql
-Priority: optional
-Section: net
-Description: an IP accounting daemon,
- built with MySQL database support
-Depends: libmysqlclient, libpcap
diff --git a/package/pmacct/ipkg/pmacctd-pgsql.control b/package/pmacct/ipkg/pmacctd-pgsql.control
deleted file mode 100644
index 7018c73509..0000000000
--- a/package/pmacct/ipkg/pmacctd-pgsql.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: pmacctd-pgsql
-Priority: optional
-Section: net
-Description: an IP accounting daemon,
- built with PostgreSQL database support
-Depends: libpq, libpcap
diff --git a/package/pmacct/ipkg/pmacctd-sqlite.control b/package/pmacct/ipkg/pmacctd-sqlite.control
deleted file mode 100644
index ad8f7c96f0..0000000000
--- a/package/pmacct/ipkg/pmacctd-sqlite.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: pmacctd-sqlite
-Priority: optional
-Section: net
-Description: an IP accounting daemon,
- built with SQLite database support
-Depends: libsqlite, libpcap
diff --git a/package/pmacct/ipkg/pmacctd.conffiles b/package/pmacct/ipkg/pmacctd.conffiles
deleted file mode 100644
index fa81c14cb8..0000000000
--- a/package/pmacct/ipkg/pmacctd.conffiles
+++ /dev/null
@@ -1,2 +0,0 @@
-/etc/default/pmacctd
-/etc/pmacctd.conf
diff --git a/package/pmacct/ipkg/pmacctd.control b/package/pmacct/ipkg/pmacctd.control
deleted file mode 100644
index 5d2cc7c4e1..0000000000
--- a/package/pmacct/ipkg/pmacctd.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: pmacctd
-Priority: optional
-Section: net
-Description: an IP accounting daemon,
- built without database support
-Depends: libpcap