aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/022-atomic64_backport.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/mac80211/patches/022-atomic64_backport.patch')
-rw-r--r--package/mac80211/patches/022-atomic64_backport.patch91
1 files changed, 0 insertions, 91 deletions
diff --git a/package/mac80211/patches/022-atomic64_backport.patch b/package/mac80211/patches/022-atomic64_backport.patch
deleted file mode 100644
index 673b7c336a..0000000000
--- a/package/mac80211/patches/022-atomic64_backport.patch
+++ /dev/null
@@ -1,91 +0,0 @@
---- a/compat/Makefile
-+++ b/compat/Makefile
-@@ -38,3 +38,8 @@ compat-$(CONFIG_COMPAT_KERNEL_3_1) += \
- cordic.o \
- crc8.o
-
-+ifndef CONFIG_64BIT
-+ifndef CONFIG_GENERIC_ATOMIC64
-+ compat-y += compat_atomic.o
-+endif
-+endif
---- a/include/linux/compat-2.6.31.h
-+++ b/include/linux/compat-2.6.31.h
-@@ -202,6 +202,20 @@ void compat_synchronize_threaded_irq(str
- #define skb_walk_frags(skb, iter) \
- for (iter = skb_shinfo(skb)->frag_list; iter; iter = iter->next)
-
-+#ifndef CONFIG_64BIT
-+
-+typedef struct {
-+ long long counter;
-+} atomic64_t;
-+
-+extern long long atomic64_read(const atomic64_t *v);
-+extern long long atomic64_add_return(long long a, atomic64_t *v);
-+
-+#define atomic64_inc_return(v) atomic64_add_return(1LL, (v))
-+
-+#endif
-+
-+
- #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)) */
-
- #endif /* LINUX_26_31_COMPAT_H */
---- /dev/null
-+++ b/compat/compat_atomic.c
-@@ -0,0 +1,33 @@
-+#include <linux/spinlock.h>
-+#include <linux/module.h>
-+
-+#if !((LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31)) && (defined(CONFIG_UML) || defined(CONFIG_X86))) && !((LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33)) && defined(CONFIG_ARM) && !defined(CONFIG_GENERIC_ATOMIC64))
-+
-+static DEFINE_SPINLOCK(lock);
-+
-+long long atomic64_read(const atomic64_t *v)
-+{
-+ unsigned long flags;
-+ long long val;
-+
-+ spin_lock_irqsave(&lock, flags);
-+ val = v->counter;
-+ spin_unlock_irqrestore(&lock, flags);
-+ return val;
-+}
-+EXPORT_SYMBOL(atomic64_read);
-+
-+long long atomic64_add_return(long long a, atomic64_t *v)
-+{
-+ unsigned long flags;
-+ long long val;
-+
-+ spin_lock_irqsave(&lock, flags);
-+ val = v->counter += a;
-+ spin_unlock_irqrestore(&lock, flags);
-+ return val;
-+}
-+EXPORT_SYMBOL(atomic64_add_return);
-+
-+#endif
-+
---- a/include/linux/compat-3.1.h
-+++ b/include/linux/compat-3.1.h
-@@ -19,6 +19,18 @@
- .prod_id = { NULL, NULL, (v3), NULL }, \
- .prod_id_hash = { 0, 0, (vh3), 0 }, }
-
-+/*
-+ * In many versions, several architectures do not seem to include an
-+ * atomic64_t implementation, and do not include the software emulation from
-+ * asm-generic/atomic64_t.
-+ * Detect and handle this here.
-+ */
-+#include <asm/atomic.h>
-+
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31)) && !defined(ATOMIC64_INIT) && !defined(CONFIG_X86) && !((LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33)) && defined(CONFIG_ARM) && !defined(CONFIG_GENERIC_ATOMIC64))
-+#include <asm-generic/atomic64.h>
-+#endif
-+
- #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(3,1,0)) */
-
- #endif /* LINUX_3_1_COMPAT_H */