aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 4ea2f3dc91..f3fe6c7d77 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1492,7 +1492,7 @@ define KernelPackage/brcmfmac/config
if PACKAGE_kmod-brcmfmac
config BRCMFMAC_SDIO
- bool "Enable SDIO support"
+ bool "Enable SDIO bus interface support"
default n
help
Enable support for cards attached to an SDIO bus.
@@ -1500,6 +1500,14 @@ define KernelPackage/brcmfmac/config
board has a Broadcom wireless chip atacched to
that bus.
+ config BRCMFMAC_PCIE
+ bool "Enable PCIE bus interface support"
+ depends on PCI_SUPPORT
+ default y
+ help
+ Supported PCIe connected chipsets:
+ BCM4354, BCM4356, BCM43567, BCM43570, BCM43602
+
endif
endef
@@ -1575,6 +1583,7 @@ config-$(call config_package,brcmsmac) += BRCMSMAC
config-$(call config_package,brcmfmac) += BRCMFMAC
config-$(CONFIG_BRCMFMAC_SDIO) += BRCMFMAC_SDIO
config-y += BRCMFMAC_USB
+config-$(CONFIG_BRCMFMAC_PCIE) += BRCMFMAC_PCIE
config-$(CONFIG_PACKAGE_BRCM80211_DEBUG) += BRCMDBG
config-$(call config_package,mac80211-hwsim) += MAC80211_HWSIM