aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 301460e416..885f40a2e6 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1072,3 +1072,39 @@ define KernelPackage/bmp085-spi/description
endef
$(eval $(call KernelPackage,bmp085-spi))
+
+
+define KernelPackage/virtio-pci
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Virtio PCI support
+ KCONFIG:= CONFIG_VIRTIO CONFIG_VIRTIO_PCI
+ FILES:=\
+ $(LINUX_DIR)/drivers/virtio/virtio_pci.ko \
+ $(LINUX_DIR)/drivers/virtio/virtio.ko \
+ $(LINUX_DIR)/drivers/virtio/virtio_ring.ko
+ AUTOLOAD:=$(call AutoProbe,virtio virtio_ring virtio_pci)
+endef
+define KernelPackage/virtio-pci/description
+ This driver adds virtio PCI support.
+endef
+
+$(eval $(call KernelPackage,virtio-pci))
+
+
+define KernelPackage/virtio-mmio
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Virtio MMIO support
+ KCONFIG:= CONFIG_VIRTIO CONFIG_VIRTIO_MMIO
+ FILES:= \
+ $(LINUX_DIR)/drivers/virtio/virtio.ko \
+ $(LINUX_DIR)/drivers/virtio/virtio_ring.ko \
+ $(LINUX_DIR)/drivers/virtio/virtio_mmio.ko
+ AUTOLOAD:=$(call AutoProbe,virtio virtio_ring virtio_mmio)
+endef
+define KernelPackage/virtio-mmio/description
+ This driver adds virtio MMIO support.
+endef
+
+$(eval $(call KernelPackage,virtio-mmio))
+
+