aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/netsupport.mk15
-rw-r--r--target/linux/x86_64/config-default2
2 files changed, 2 insertions, 15 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index a3abf0da08..badd54231b 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -144,24 +144,13 @@ endef
$(eval $(call KernelPackage,8021q))
-define KernelPackage/udptunnel6
- SUBMENU:=$(NETWORK_SUPPORT_MENU)
- TITLE:=UDP tunneling support
- DEPENDS:=@!(LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14) +kmod-ipv6
- KCONFIG:=CONFIG_NET_UDP_TUNNEL
- FILES:=$(LINUX_DIR)/net/ipv6/ip6_udp_tunnel.ko
- AUTOLOAD:=$(call AutoLoad,32,ip6_udp_tunnel)
-endef
-
-$(eval $(call KernelPackage,udptunnel6))
-
define KernelPackage/vxlan
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Native VXLAN Kernel support
- DEPENDS:=+kmod-iptunnel +IPV6:kmod-udptunnel6
+ DEPENDS:=+kmod-iptunnel
KCONFIG:=CONFIG_VXLAN
FILES:=$(LINUX_DIR)/drivers/net/vxlan.ko
- AUTOLOAD:=$(call AutoLoad,33,vxlan)
+ AUTOLOAD:=$(call AutoLoad,13,vxlan)
endef
define KernelPackage/vxlan/description
diff --git a/target/linux/x86_64/config-default b/target/linux/x86_64/config-default
index dbbb3e84e8..dde8b25499 100644
--- a/target/linux/x86_64/config-default
+++ b/target/linux/x86_64/config-default
@@ -345,8 +345,6 @@ CONFIG_PARAVIRT_CLOCK=y
# CONFIG_PARAVIRT_TIME_ACCOUNTING is not set
# CONFIG_PC87413_WDT is not set
CONFIG_PCI=y
-CONFIG_PCIEAER=y
-CONFIG_PCIEPORTBUS=y
CONFIG_PCI_DIRECT=y
CONFIG_PCI_DOMAINS=y
# CONFIG_PCI_IOAPIC is not set