aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/host.mk4
-rw-r--r--toolchain/kernel-headers/Makefile3
2 files changed, 6 insertions, 1 deletions
diff --git a/include/host.mk b/include/host.mk
index b4580e2b7a..6458881472 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -22,3 +22,7 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-e 's/cris.*/cris/' \
-e 's/i[3-9]86/i386/'`" >> $@
echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+ if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+ echo "TAR_OPTIONS+=--wildcards" >> $@; \
+ fi
+
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index 7b5c06c781..3e2cd2ae86 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -29,9 +29,10 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-e 's/armeb/arm/' \
)
+
define Build/Prepare
mkdir -p $(TOOLCHAIN_BUILD_DIR)
- bzcat $(DL_DIR)/$(PKG_SOURCE) | tar --wildcards -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
+ bzcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
linux-$(PKG_VERSION)/include \
linux-$(PKG_VERSION)/Makefile \
linux-$(PKG_VERSION)/Rules.make \