aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/default/Makefile.in1
-rw-r--r--target/default/openwrt.mk10
2 files changed, 11 insertions, 0 deletions
diff --git a/target/default/Makefile.in b/target/default/Makefile.in
new file mode 100644
index 0000000000..872750df41
--- /dev/null
+++ b/target/default/Makefile.in
@@ -0,0 +1 @@
+TARGETS+=openwrt-image
diff --git a/target/default/openwrt.mk b/target/default/openwrt.mk
new file mode 100644
index 0000000000..89051cd1bf
--- /dev/null
+++ b/target/default/openwrt.mk
@@ -0,0 +1,10 @@
+openwrt-linux.trx: openwrt-trx
+ PATH=$(TARGET_PATH) trx -o openwrt-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+
+openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
+ PATH=$(TARGET_PATH) addpattern -2 -i openwrt-linux.trx -o openwrt-gs-code.bin -g
+
+openwrt-g-code.bin: openwrt-gs-code.bin
+ sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin > openwrt-g-code.bin
+
+openwrt-image: openwrt-g-code.bin