aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-07-07 14:46:32 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-07-07 14:46:32 +0200
commita935e22d06b2c354247b3b004c285ede9cd84f58 (patch)
tree22c94d6b3a972ac280ea31fd466a2d446d3a77ef /tools
parent347143af0dce63ac4672ba5b4c9291c6a696e210 (diff)
downloadmaster-187ad058-a935e22d06b2c354247b3b004c285ede9cd84f58.tar.gz
master-187ad058-a935e22d06b2c354247b3b004c285ede9cd84f58.tar.bz2
master-187ad058-a935e22d06b2c354247b3b004c285ede9cd84f58.zip
tools/cmake: fix parallel build with Make 4.2+
Avoid using the --parallel argument to the CMake bootstrap, as that doesn't allow us to remove the -j argument. Instead, pass the HOST_JOBS arguments in MAKEFLAGS. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'tools')
-rw-r--r--tools/cmake/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index da62f70745..aaa3b33f4f 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -19,10 +19,11 @@ HOST_CONFIGURE_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+HOST_CONFIGURE_CMD := MAKEFLAGS="$(HOST_JOBS)" $(BASH) ./configure
+
HOST_CONFIGURE_VARS :=
HOST_CONFIGURE_ARGS := \
- --prefix=$(STAGING_DIR_HOST) \
- $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
+ --prefix=$(STAGING_DIR_HOST)
$(eval $(call HostBuild))