aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-18 19:00:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-18 19:00:05 +0000
commit1f095900a2b62d49f49977a85fa2b1e0ef806495 (patch)
tree3775ecd28a8a1b6ff55b21ac0e8fc59bc3fc61b3 /tools
parentd8f112a0544af40966990979aae1fc133d558c5c (diff)
downloadmaster-187ad058-1f095900a2b62d49f49977a85fa2b1e0ef806495.tar.gz
master-187ad058-1f095900a2b62d49f49977a85fa2b1e0ef806495.tar.bz2
master-187ad058-1f095900a2b62d49f49977a85fa2b1e0ef806495.zip
improve parallel building
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5208 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index c8fad23236..eeadde2ed6 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -16,7 +16,9 @@ TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
all: install
download: $(TARGETS_DOWNLOAD)
-install: $(TARGETS_INSTALL)
+install:
+ $(MAKE) install-targets
+install-targets: $(TARGETS_INSTALL)
clean: $(TARGETS_CLEAN)
squashfs-compile: lzma-install
@@ -58,3 +60,8 @@ $(TOOL_BUILD_DIR):
@$(MAKE) -C $(patsubst %-clean,%,$@) clean
@rm -f $(TOOL_STAMP_DIR)/.tool_$(patsubst %-clean,%,$@)-*
+ifeq ($(MAKECMDGOALS),install-targets)
+MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
+else
+.NOTPARALLEL:
+endif