aboutsummaryrefslogtreecommitdiffstats
path: root/tools/dosfstools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
commitf120a607293fcb09054ba34dc0491e8c31561375 (patch)
tree7ca8e633445d23dee7adb03246b4127a87c12079 /tools/dosfstools
parente51c7c8ba15543f4f88897631005e7857819b12c (diff)
downloadmaster-187ad058-f120a607293fcb09054ba34dc0491e8c31561375.tar.gz
master-187ad058-f120a607293fcb09054ba34dc0491e8c31561375.tar.bz2
master-187ad058-f120a607293fcb09054ba34dc0491e8c31561375.zip
[tools] use HOST_STATIC_LINKING instead of hardcoding -static
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33140 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/dosfstools')
-rw-r--r--tools/dosfstools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/dosfstools/Makefile b/tools/dosfstools/Makefile
index 73d8e2a36a..c58248910b 100644
--- a/tools/dosfstools/Makefile
+++ b/tools/dosfstools/Makefile
@@ -16,7 +16,7 @@ PKG_CAT:=zcat
include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="$(HOST_LDFLAGS) -static"
+ $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)"
endef
define Host/Install