aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-18 23:38:26 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-18 23:38:26 +0000
commit66f724f3ad51c9b0de1c2cae3b22c69e08e51e49 (patch)
treeff8a843d6d793b6ea9350021f50259a69ee7184e /tools/cmake/patches
parent0cbcc1e6b2fbd85f1d4da34193f8936345e173e8 (diff)
downloadmaster-187ad058-66f724f3ad51c9b0de1c2cae3b22c69e08e51e49.tar.gz
master-187ad058-66f724f3ad51c9b0de1c2cae3b22c69e08e51e49.tar.bz2
master-187ad058-66f724f3ad51c9b0de1c2cae3b22c69e08e51e49.zip
[tools] cmake: upgrade to 2.8.12
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38457 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/cmake/patches')
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch12
1 files changed, 8 insertions, 4 deletions
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index 26ad89c2f1..3d44dac53f 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,21 +1,25 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -76,12 +76,6 @@ add_RunCMake_test(include_directories)
- add_RunCMake_test(list)
- add_RunCMake_test(CMP0004)
+@@ -101,16 +101,6 @@
+ add_RunCMake_test(TargetPolicies)
+ add_RunCMake_test(alias_targets)
-find_package(Qt4 QUIET)
-find_package(Qt5Core QUIET)
-if (QT4_FOUND AND Qt5Core_FOUND AND NOT Qt5Core_VERSION VERSION_LESS 5.1.0)
- add_RunCMake_test(IncompatibleQt)
-endif()
+-if (QT4_FOUND)
+- set(ObsoleteQtMacros_ARGS -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
+- add_RunCMake_test(ObsoleteQtMacros)
+-endif()
-
if("${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio [^6]")
add_RunCMake_test(include_external_msproject)
add_RunCMake_test(SolutionGlobalSections)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -259,10 +259,6 @@ if(BUILD_TESTING)
+@@ -262,10 +262,6 @@
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})