aboutsummaryrefslogtreecommitdiffstats
path: root/tools/automake/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-03-24 13:13:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-03-24 13:13:01 +0000
commit67b5aaaf65a2f0a8a46a4d5f87e2940fd4a01717 (patch)
treece8d0f4efdab65a5231d3710def90910faa8d32c /tools/automake/Makefile
parentce0ba6006865f5fd67df7d359db05ec7c2de73a9 (diff)
downloadmaster-187ad058-67b5aaaf65a2f0a8a46a4d5f87e2940fd4a01717.tar.gz
master-187ad058-67b5aaaf65a2f0a8a46a4d5f87e2940fd4a01717.tar.bz2
master-187ad058-67b5aaaf65a2f0a8a46a4d5f87e2940fd4a01717.zip
automake: portability fixes
The rework of the host tools discovery caused automake to embed absolute paths to staging_dir/host/bin/perl into the shebang of the generated automake executables. Switch to the portable "/usr/bin/env perl" and enable global warnings through "$^W" instead of the "-w" interpreter argument. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44972 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/automake/Makefile')
-rw-r--r--tools/automake/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 6395d84387..0eea101983 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -19,7 +19,9 @@ HOST_CONFIGURE_ARGS += \
--datarootdir=$(STAGING_DIR_HOST)/share \
--disable-silent-rules
-HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
+HOST_CONFIGURE_VARS += \
+ PERL="/usr/bin/env perl" \
+ am_cv_prog_PERL_ithreads=no
define Host/Configure
(cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)