aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-10-02 00:18:16 +0000
committerNicolas Thill <nico@openwrt.org>2009-10-02 00:18:16 +0000
commite4c4504874af8428d96416cce1a9f282c767299e (patch)
tree8b67d66bf39d154b99c58daefad4f9b935461b0e /toolchain
parent96170b8c3ed4b5f7e9cf1d225e41ea436ea2023d (diff)
downloadmaster-187ad058-e4c4504874af8428d96416cce1a9f282c767299e.tar.gz
master-187ad058-e4c4504874af8428d96416cce1a9f282c767299e.tar.bz2
master-187ad058-e4c4504874af8428d96416cce1a9f282c767299e.zip
[toolchain] uClibc: remove absolute path linking to host libraries in libpthread.so (closes: #5601)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17814 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 7206df2720..1d18bffb49 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -103,15 +103,15 @@ define Host/Compile
$(UCLIBC_MAKE) PREFIX="$(TOOLCHAIN_DIR)/" install_runtime install_dev
ln -sf ../../lib/libc.so.0 $(TOOLCHAIN_DIR)/usr/lib/libc.so
$(CP) $(HOST_BUILD_DIR)/libc/libc_so.a $(TOOLCHAIN_DIR)/usr/lib/
-# ( cd $(TOOLCHAIN_DIR) ; \
-# for d in lib usr/lib ; do \
-# for f in libc.so libpthread.so libgcc_s.so ; do \
-# if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
-# $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
-# fi \
-# done \
-# done \
-# )
+ ( cd $(TOOLCHAIN_DIR) ; \
+ for d in lib usr/lib ; do \
+ for f in libc.so libpthread.so libgcc_s.so ; do \
+ if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
+ $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
+ fi \
+ done \
+ done \
+ )
endef
define Host/Install