aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-03-06 17:10:45 +0000
committerNicolas Thill <nico@openwrt.org>2010-03-06 17:10:45 +0000
commit88a144a5d28e91f3e744ed81746febf7cbab9250 (patch)
tree53fdda6bf17d689b7d8cfcc2482755b2a95e3fbf /toolchain
parent93cdb999f49192c5b84ba2f09a84f368bce95b56 (diff)
downloadmaster-187ad058-88a144a5d28e91f3e744ed81746febf7cbab9250.tar.gz
master-187ad058-88a144a5d28e91f3e744ed81746febf7cbab9250.tar.bz2
master-187ad058-88a144a5d28e91f3e744ed81746febf7cbab9250.zip
[toolchain] gcc: only enable/disable TLS support in final stage (closes: #6788)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20018 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 9c820f2fec..9536cc245b 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -116,11 +116,6 @@ else
--disable-libssp
endif
-ifeq ($(CONFIG_TLS_SUPPORT),)
- GCC_CONFIGURE+= \
- --disable-tls
-endif
-
ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
GCC_CONFIGURE+= \
--enable-biarch \
@@ -159,6 +154,14 @@ GCC_CONFIGURE_STAGE2:= \
--enable-threads \
--with-slibdir=$(TOOLCHAIN_DIR)/lib \
+ifneq ($(CONFIG_TLS_SUPPORT),)
+ GCC_CONFIGURE_STAGE2+= \
+ --enable-tls
+else
+ GCC_CONFIGURE_STAGE2+= \
+ --disable-tls
+endif
+
ifdef CONFIG_powerpc
TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
endif