aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-02-25 16:52:25 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-02-25 16:52:25 +0000
commit7dd2d2cbd3e516107edb4cf20469206b93a1edec (patch)
tree53c32ea18521043aae12d81eba831be518db0e09 /toolchain
parentc4b79f390411d319afde53231f6b3c5a01e28142 (diff)
downloadmaster-187ad058-7dd2d2cbd3e516107edb4cf20469206b93a1edec.tar.gz
master-187ad058-7dd2d2cbd3e516107edb4cf20469206b93a1edec.tar.bz2
master-187ad058-7dd2d2cbd3e516107edb4cf20469206b93a1edec.zip
We use different toolchain directories for different
ARM archs, so we should set the default arch of gcc to reflect this. This enables EABI support for armv4 CPUs. Signed-off-by: Jochen Friedrich <jochen@scram.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25705 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in2
-rw-r--r--toolchain/gcc/common.mk4
2 files changed, 4 insertions, 2 deletions
diff --git a/toolchain/Config.in b/toolchain/Config.in
index 318847f736..bc9e6df06d 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -90,8 +90,6 @@ config EABI_SUPPORT
bool
depends arm||armeb
prompt "Enable EABI support" if TOOLCHAINOPTS
- default n if TARGET_gemini
- default n if TARGET_cns21xx
default y
help
Enable ARM EABI support
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 0f22e41021..888cf7a1e5 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -167,6 +167,10 @@ ifdef CONFIG_powerpc
TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
endif
+ifneq ($(GCC_ARCH),)
+ GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
+endif
+
GCC_MAKE:= \
export SHELL="$(BASH)"; \
$(MAKE) $(TOOLCHAIN_JOBS) \