aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-12-10 14:24:24 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-12-10 14:24:24 +0000
commit415894edf2018706f462db4c721133ec9b471cda (patch)
treeb9ccd1fea7a957116b15998f30c47414d8386d28 /toolchain
parent6c8a0f138947015cde8d428477f66f40c5cfd6b6 (diff)
downloadmaster-187ad058-415894edf2018706f462db4c721133ec9b471cda.tar.gz
master-187ad058-415894edf2018706f462db4c721133ec9b471cda.tar.bz2
master-187ad058-415894edf2018706f462db4c721133ec9b471cda.zip
toolchain/musl: simplify musl install steps
Some of these were copy/pasted from uClibc, but they are not necessary at all for musl-libc. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34598 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/musl/Makefile12
1 files changed, 0 insertions, 12 deletions
diff --git a/toolchain/musl/Makefile b/toolchain/musl/Makefile
index 79ea175a46..f95bb05ce2 100644
--- a/toolchain/musl/Makefile
+++ b/toolchain/musl/Makefile
@@ -21,18 +21,6 @@ endef
define Host/Install
$(call Host/SetToolchainInfo)
$(MAKE) -C $(HOST_BUILD_DIR) DESTDIR="$(TOOLCHAIN_DIR)/" install
- ( cd $(TOOLCHAIN_DIR) ; \
- for d in lib usr/lib ; do \
- for f in libc.so libpthread.so libgcc_s.so ; do \
- if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
- $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
- fi \
- done \
- done \
- )
- rm -f \
- $(TOOLCHAIN_DIR)/lib/libresolv*.so* \
- $(TOOLCHAIN_DIR)/lib/libnsl*.so*
endef
$(eval $(call HostBuild))