aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 22:01:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 22:01:29 +0000
commitaf048b68e3b5229bdbdb39863a1cd926fe587b66 (patch)
treeab0d2490cc1588101c972460738c5379c42110ca /toolchain/uClibc/Makefile
parenta5ff10dd74547893c20294bb0c87c6ebb725c14b (diff)
downloadmaster-187ad058-af048b68e3b5229bdbdb39863a1cd926fe587b66.tar.gz
master-187ad058-af048b68e3b5229bdbdb39863a1cd926fe587b66.tar.bz2
master-187ad058-af048b68e3b5229bdbdb39863a1cd926fe587b66.zip
fix an uClibc compile error that only happens on rebuilds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8248 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 7fce989542..d6ef6a3438 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -37,7 +37,6 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
define Build/Prepare
$(call Build/Prepare/Default)
- $(SED) 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(PKG_BUILD_DIR)/Rules.mak
if [ -e config/$(ARCH).$(BOARD) ]; then \
$(CP) config/$(ARCH).$(BOARD) $(PKG_BUILD_DIR)/.config; \
else \
@@ -73,6 +72,7 @@ define Build/Configure
endef
define Build/Compile
+ $(SED) 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(PKG_BUILD_DIR)/Rules.mak
PATH=$(TARGET_PATH) $(MAKE) -j $(CONFIG_JLEVEL) -C $(PKG_BUILD_DIR) \
PREFIX= \
DEVEL_PREFIX=/ \