aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-11-24 00:30:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-11-24 00:30:26 +0000
commit9df9184b94ca50df8d45a1172f2d009bb5dd28b8 (patch)
treed470694eb71da0e9eb060152f5859d96724d8374 /toolchain/uClibc/Makefile
parent53af0d5fbb3c2ff5a704f15fab95ead1df5581bf (diff)
downloadmaster-187ad058-9df9184b94ca50df8d45a1172f2d009bb5dd28b8.tar.gz
master-187ad058-9df9184b94ca50df8d45a1172f2d009bb5dd28b8.tar.bz2
master-187ad058-9df9184b94ca50df8d45a1172f2d009bb5dd28b8.zip
uClibc: add back a few cflags that were being overwritten, might fix a few segfauls (thx, framer99)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24120 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 0df26d097f..c5dea08bb4 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -101,12 +101,17 @@ endef
define Host/Configure
endef
+CPU_CFLAGS = \
+ -funsigned-char -fno-builtin -fno-asm \
+ --std=gnu99 -ffunction-sections -fdata-sections \
+ $(TARGET_CFLAGS)
+
UCLIBC_MAKE = PATH='$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
DEVEL_PREFIX=/ \
RUNTIME_PREFIX=/ \
HOSTCC="$(HOSTCC)" \
- CPU_CFLAGS="$(TARGET_CFLAGS)" \
+ CPU_CFLAGS="$(CPU_CFLAGS)" \
ARCH="$(CONFIG_ARCH)" \
LIBGCC="$(subst libgcc.a,libgcc_initial.a,$(shell $(TARGET_CC) -print-libgcc-file-name))" \
DOSTRIP=""