aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2005-03-06 03:34:52 +0000
committerMike Baker <mbm@openwrt.org>2005-03-06 03:34:52 +0000
commit3d904bb14a330fb72f60d4b78a40435389398655 (patch)
tree4c6922d42353c39b46dcd7cd09982fbe9c1f9765 /toolchain/uClibc/Makefile
parentb92a98900c8308542da9f758cd656880081f1196 (diff)
downloadmaster-187ad058-3d904bb14a330fb72f60d4b78a40435389398655.tar.gz
master-187ad058-3d904bb14a330fb72f60d4b78a40435389398655.tar.bz2
master-187ad058-3d904bb14a330fb72f60d4b78a40435389398655.zip
nbd's makefile/menuconfig rewrite
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@307 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
new file mode 100644
index 0000000000..06d7487a4f
--- /dev/null
+++ b/toolchain/uClibc/Makefile
@@ -0,0 +1,10 @@
+include $(TOPDIR)/rules.mk
+
+include ./uclibc.mk
+
+source: uclibc-source
+prepare: uclibc-configured
+compile: $(UCLIBC_DIR)/lib/libc.a
+install: uclibc
+ $(STRIP) $(TARGET_DIR)/lib/*.so
+clean: uclibc-clean