aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-04 18:41:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-04 18:41:08 +0000
commit1b6675367e2e57bb7fe3ae7edcd7b802004b839c (patch)
tree490ca362da7532b93334f1b28844ba999da2f2af /toolchain/uClibc/Makefile
parentfe799c19a6b8d1a5a4f4e1fcee3eba9bf58cbca4 (diff)
downloadmaster-187ad058-1b6675367e2e57bb7fe3ae7edcd7b802004b839c.tar.gz
master-187ad058-1b6675367e2e57bb7fe3ae7edcd7b802004b839c.tar.bz2
master-187ad058-1b6675367e2e57bb7fe3ae7edcd7b802004b839c.zip
fix the uclibc rebuild issue which leads to unresolved symbols in libnl (and possibly other libraries)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15599 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index e8407fb9c5..b55796b40f 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -88,12 +88,13 @@ endef
define Host/Configure
endef
-UCLIBC_MAKE := PATH=$(TARGET_PATH) $(MAKE) -C $(HOST_BUILD_DIR) \
+UCLIBC_MAKE = PATH=$(TARGET_PATH) $(MAKE) -C $(HOST_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
DEVEL_PREFIX=/usr/ \
RUNTIME_PREFIX=/ \
HOSTCC="$(HOSTCC)" \
CPU_CFLAGS="$(TARGET_CFLAGS)" \
+ LIBGCC="$(subst libgcc.a,libgcc_initial.a,$(shell $(TARGET_CC) -print-libgcc-file-name))" \
DOSTRIP=""
define Host/Compile