aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/libnotimpl/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-07 17:05:47 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-07 17:05:47 +0000
commitc15e3f4c15e134d32d2993fdc65df31d56fce5e1 (patch)
tree47c9776cfcced9e34e2f78c487b8c6e0ffc1d1a1 /toolchain/libnotimpl/Makefile
parentc86f780376e57ac0c657290677807617d6911941 (diff)
downloadmaster-187ad058-c15e3f4c15e134d32d2993fdc65df31d56fce5e1.tar.gz
master-187ad058-c15e3f4c15e134d32d2993fdc65df31d56fce5e1.tar.bz2
master-187ad058-c15e3f4c15e134d32d2993fdc65df31d56fce5e1.zip
rename toolchain/libmissing to libnotimpl (fix dnsiff build)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2065 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/libnotimpl/Makefile')
-rw-r--r--toolchain/libnotimpl/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/toolchain/libnotimpl/Makefile b/toolchain/libnotimpl/Makefile
new file mode 100644
index 0000000000..9ae2bf2407
--- /dev/null
+++ b/toolchain/libnotimpl/Makefile
@@ -0,0 +1,30 @@
+include $(TOPDIR)/rules.mk
+
+LIBNOTIMPL_DIR:=$(TOOL_BUILD_DIR)/libnotimpl
+
+LIBNOTIMPL_SRCS+=./files/math.c
+LIBNOTIMPL_OBJS:=$(patsubst ./files/%.c,$(LIBNOTIMPL_DIR)/%.o,$(LIBNOTIMPL_SRCS))
+
+$(LIBNOTIMPL_DIR)/.prepared:
+ mkdir -p $(LIBNOTIMPL_DIR)
+ touch $@
+
+$(LIBNOTIMPL_OBJS): $(LIBNOTIMPL_DIR)/%.o : ./files/%.c
+ $(TARGET_CC) $(TARGET_CFLAGS) -c $< -o $@
+
+$(LIBNOTIMPL_DIR)/libnotimpl.a: $(LIBNOTIMPL_OBJS)
+ $(TARGET_CROSS)ar rc $(LIBNOTIMPL_DIR)/libnotimpl.a $(LIBNOTIMPL_OBJS)
+
+$(STAGING_DIR)/usr/lib/libnotimpl.a: $(LIBNOTIMPL_DIR)/libnotimpl.a
+ mkdir -p $(STAGING_DIR)/usr/lib
+ cp -fpR $< $@
+ touch -c $@
+
+source:
+prepare: $(LIBNOTIMPL_DIR)/.prepared
+compile: $(LIBNOTIMPL_DIR)/libnotimpl.a
+install: $(STAGING_DIR)/usr/lib/libnotimpl.a
+clean:
+ rm -rf \
+ $(STAGING_DIR)/usr/lib/libnotimpl.a \
+ $(LIBNOTIMPL_DIR) \