aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/common.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-29 23:19:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-29 23:19:31 +0000
commit3dd3913679b2849fb1eb3b41c28a897118355ba8 (patch)
treea9beb57cbb66cc2a46e727241f5cc9ec80ad66f8 /toolchain/glibc/common.mk
parent0f937d567f3ac0fb45d065dd18f8ce72e4597a5a (diff)
downloadmaster-187ad058-3dd3913679b2849fb1eb3b41c28a897118355ba8.tar.gz
master-187ad058-3dd3913679b2849fb1eb3b41c28a897118355ba8.tar.bz2
master-187ad058-3dd3913679b2849fb1eb3b41c28a897118355ba8.zip
glibc: switch to downloading version 2.22 via tarball instead of git to improve mirror support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48556 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/glibc/common.mk')
-rw-r--r--toolchain/glibc/common.mk19
1 files changed, 13 insertions, 6 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index bc50fcb69e..14063bf9df 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -8,13 +8,20 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=glibc
PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
-PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
-PKG_SOURCE_VERSION:=$(PKG_REVISION)
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
-PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
+ifeq ($(PKG_VERSION),2.22)
+ PKG_SOURCE_URL:=http://ftpmirror.gnu.org/libc
+ PKG_MD5SUM:=eb731406903befef1d8f878a46be75ef862b9056ab0cde1626d08a7a05328948
+ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+ PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.xz
+else
+ PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
+ PKG_SOURCE_PROTO:=git
+ PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
+ PKG_SOURCE_VERSION:=$(PKG_REVISION)
+ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
+ PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
+endif
GLIBC_PATH:=
ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)