aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/4.8-linaro
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-02-24 21:09:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-02-24 21:09:37 +0000
commit2c60412f00cbf5d2877e7041fd7c672ebe21fb6e (patch)
tree84d379e8dee5b70180e7d9a073b8f03ce30ccedf /toolchain/gcc/patches/4.8-linaro
parentef48b885cf19432985ba975edb1645c865e52047 (diff)
downloadmaster-187ad058-2c60412f00cbf5d2877e7041fd7c672ebe21fb6e.tar.gz
master-187ad058-2c60412f00cbf5d2877e7041fd7c672ebe21fb6e.tar.bz2
master-187ad058-2c60412f00cbf5d2877e7041fd7c672ebe21fb6e.zip
gcc: fix visibility of symbols libgcc.a
Symbols need to be hidden, even for the static variant Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39749 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/patches/4.8-linaro')
-rw-r--r--toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch11
1 files changed, 0 insertions, 11 deletions
diff --git a/toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch b/toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch
index ee3f602731..6fa19241f5 100644
--- a/toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch
@@ -33,17 +33,6 @@
- printf ("\n local:\n\t*;\n};\n");
+ printf ("\n\t*;\n};\n");
}
---- a/libgcc/Makefile.in
-+++ b/libgcc/Makefile.in
-@@ -368,7 +368,7 @@ endif
- # For -fvisibility=hidden. We need both a -fvisibility=hidden on
- # the command line, and a #define to prevent libgcc2.h etc from
- # overriding that with #pragmas.
--vis_hide = @vis_hide@
-+vis_hide =
-
- ifneq (,$(vis_hide))
-
--- a/gcc/config/rs6000/linux.h
+++ b/gcc/config/rs6000/linux.h
@@ -61,6 +61,9 @@